Exchange 2010 Active sync issue

Hi all, i have an issue whereby i am trying to get an activesync connection to work on a new CAS server and an given the following error when doing a test-activesyncconnectivity

"[System.Net.WebException]: The underlying connection was closed: Could not establish trust relationship for the SSL/TLSsecure channel. Inner error [System.Security.Authentication.AuthenticationException]: The remote certificate is invalid according to the vaildation procedure"

when i run with the -trustanysslcertificate it works great see screen shot. What can i do to fix this error.

thanks
Capture.JPG
LVL 15
cwstad2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guillermo FeijóoSystems administratorCommented:
have a look here

https://technet.microsoft.com/en-us/library/bb266938%28v=exchg.141%29.aspx

i would start checking this

"If you are using an SSL certificate that was created during Exchange Setup, an error message notifies you that the certificate is not a trusted certificate. Make sure that you trust the certification authority (CA) that issued the certificate or use an SSL certificate that is trusted by your CA."
0
Nathan HawkinsTechnical Lead - Network SecurityCommented:
You can create new certificates from within Exchange and assign them to the services you want that certificate to encrypt. Its pretty intuitive. Go to servers, then certificates, click the plus sign and follow the prompts. During the process you can assign the cert to specific servers, so for you set-up it will be trusted for ANY other computer the certs will not at lease not until you import the cert into each computers' trusted root ca store or use a GPO to force the trust certificate policy domain wide.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cwstad2Author Commented:
Hi i get this error when doing tyhe active sync test

Attempting to send the OPTIONS command to the server.
       Testing of the OPTIONS command failed. For more information, see Additional Details.
       
      Additional Details
       
An HTTP 403 forbidden response was received. The response appears to have come from IIS7. Body of the response: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>403 - Forbidden: Access is denied.</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;}
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;}
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
background-color:#555555;}
#content{margin:0 0 0 2%;position:relative;}
.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
-->
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
<div class="content-container"><fieldset>
<h2>403 - Forbidden: Access is denied.</h2>
<h3>You do not have permission to view this directory or page using the credentials that you supplied.</h3>
</fieldset></div>
</div>
</body>
</html>
HTTP Response Headers:
Content-Length: 1233
Cache-Control: private
Content-Type: text/html
Date: Wed, 13 May 2015 13:57:24 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 41852 ms.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Guillermo FeijóoSystems administratorCommented:
Seems you have to configure activesync virtual directory permissions/authentication

https://technet.microsoft.com/en-us/library/aa998363(v=exchg.141).aspx
0
Guillermo FeijóoSystems administratorCommented:
Seems you have to configure activesync virtual directory permissions/authentication

https://technet.microsoft.com/en-us/library/aa998363(v=exchg.141).aspx
0
Guillermo FeijóoSystems administratorCommented:
Seems you have to configure activesync virtual directory permissions/authentication

https://technet.microsoft.com/en-us/library/aa998363(v=exchg.141).aspx
0
cwstad2Author Commented:
Hi guys i resloved the issue myself. i reset the virtual directory and this allowed the mail to flow to the devices.

thanks for your help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.