Server 2012 RDWeb internal / external domain name mismatch

I have a 2012 R2 RDS single server set up and am having difficulty accessing the RDS session from RDWeb. The RDS server contains all roles:
Connection Broker, Session Host, Gateway, and Web Access.

The server is named RDS.domain.local
The local domain is domain.local

Internally, I can access https://localhost/RDWeb/ and I am presented with the collection containing an RDS session. This works fine.
I have an A record externally pointing to Remote.domainname.com
I can access RDWeb from this url: https://remote.domainname.com/RDWeb

I can log in and authenticate, and am presented with the RDP icon for the RDS session. But, when I click it, it opens RDP but I get an error:
"Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable. Try reconnecting later or contact your network administrator for assistance."

I CAN use the RDP client and enter the gateway settings of remote.domainname.com and use the computername of rds.domainname.local externally and this DOES work.

I think the issue is with a domain mismatch, or since remote is not the name of the RDS server. I believe this because I had set this up in another environment where the domain and servername matched the gateway and RDweb server. What I mean is this:

Working environment:
internal domain name: domainname.com
external domain name: domainname.com
RDS / Gateway server: remote.domainname.com
RDWeb URL:  https://remote.domainname.com/RDWeb

Non-working environment:
internal domain name: domainname.local
external domain name: domainname.com
RDS / Gateway server: rds.domainname.local
RDWeb URL:  https://remote.domainname.com/RDWeb

Please note above the difference in .local and .com, also the name of the server. I believe I need to change something in IIS to redirect remote.domainname.com to rds.domainname.local but I need some guidance as to if I am on the right path, and how to correct this. Thanks in advance!
LVL 1
CCtechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
You don't need to change IIS, and the issue isn't the .local name. SBS and essentials both rely on the RDGateway service and they use .local by default. The configuration works.

The issue is likely that you haven't configured your RDS deployment to include the RDGateway server name in the published RDP files. You turn this on and off in the RDS pane in Server Manager in 2012. Also ensure you've specified the external rdgateway name in its settings in the same pane.

Finally, for troubleshooting purposes, you can save the .rdp file from rdweb and then view it in notepad to see what settings rdweb is sending. Compare that to a file you create yourself that works. That'll usually tell you what settings are wrong or misconfigured.
0
CCtechAuthor Commented:
In the Deployment Properties under the RD Gateway section, I have "Use these RD Gateway server settings: remote.domainname.com

Is that not correct?

Also, I can open my RDP file in notepad, but how do I go about saving the RDP file from RDweb to compare?
0
CCtechAuthor Commented:
Please see screenshot. This is the RDP file that comes up when I click the RDP icon in RDWeb externally.
Untitled.jpg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.