Lightbox leaves whitespace next to images

Hello,

I am using a plugin for my Wordpress site called FooBox which puts various elements in lightboxes.  The size of the lightbox should conform to the size of the image, but instead the images have extra white space either to the sides or on the bottom.  I have made sure that the images are small enough to fit in the monitor size.

A page can be viewed at the url below. Near the bottom, the Photo Galleries and Accessories sections are having the issues.  I have attached a screenshot.

http://canflex.howitworks.com/environmental-oil-spill-response/oil-spill-storage-towable-bladders/

Any help would be greatly appreciated.

Tia
experts-exchange.PNG
tiabradford1984Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lucas BishopClick TrackerCommented:
In looking at your galleries, Foobox is loading each image in an iframed page:
iframe.PNG
However, when looking at the regular foobox demo, the images are not loaded in iframes:
foobox.PNG
It appears that maybe you are creating your galleries in a way that is not compatible with Foobox. I believe foobox is sizing responsively to the entire page loaded in the iframe, instead of to the images.

Since foobox isn't an image gallery system, I suspect the image gallery plugin you are using has a setting you should be looking into, for dictating if iframes should be used in the gallery.
mark brownCommented:
Hey Tia,
You can try out other alternatives to foobox (foobox seems slow to me) like JackBox, Flare, MetroBox etc.
tiabradford1984Author Commented:
Hi,

I've have checked all the settings for the plugin itself and any others I thought may be affecting it, but could not find any.  I will keep trying and report back when I can at least narrow down the iframe issue.

Tia
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Lucas BishopClick TrackerCommented:
It looks like links are opened into an iframe by default when you specify "foobox" as both class and target on your gallery links:
http://docs.fooplugins.com/foobox/iframes/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tiabradford1984Author Commented:
Success!  You are my new hero! Thank you so much.  I went into each image and changed the FooGallery option back to Default instead of Foobox and it works perfectly.  You saved both my job and my sanity. :)

Tia
tiabradford1984Author Commented:
Great feedback, and very responsive.  Had my issue solved right away.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.