• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4593
  • Last Modified:

Dell Sonicwall DNS Resolution problem when using NetExtender VPN

Hello Experts,
I am testing a setup using Dell's VPN client NetExtender. I have it setup so I can connect to the network using the NetExtender client, however I cannot resolve by domainname..so if I try to ping a server on the network by name, or access a network resource by name, it does not work..I can ping by ip address.

If I UNCHECK "append parent suffixes of the parent suffix" in the DNS setup of the client PC, I can then resolve by name...If I go back in right after that and CHECK "append parent suffixes of the parent suffix", it will now resolve by name. If I reboot, it goes back to not working again when checked, etc.

Why would it not work when it's check, work when it's unchecked, then work when it's checked after that. I'm assuming it puts something is cache...Also do I need "append parent suffixes of the parent suffix" checked or not?
0
ChiIT
Asked:
ChiIT
  • 5
  • 3
1 Solution
 
ChiITAuthor Commented:
UPDATE - I just did a test..I actually don't think it has to do with it "append parent suffixes of the parent suffix" is turned on or off..its turning it on or off does something to allow resolution by name....?
0
 
dmwynneCommented:
What DNS servers are assigned to the Netextender client?  You can set it up to use an internal DNS server and that should fix the issue.

On the SonicWall appliance, browse to SSL VPN > Client Settings.

Click CONFIGURE to get a pop up window and navigate to Client Settings tab.  Add DNS and suffix.

Click OK to save your changes.
0
 
ChiITAuthor Commented:
Hi dmwynne,
I have the DNS server IP and domain name in those settings, however it does not work except for how I described above.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
dmwynneCommented:
When you are pinging by name did you try the fqdn name?  What are you using for domain when you connect with the Netextender?
0
 
ChiITAuthor Commented:
when I ping the FQDN is resolves...The sonicwall domain name setup in the SSLVPN is domainname.local. when I ping servername.domainname.local it resolves. when I ping domainname, it does not.
0
 
dmwynneCommented:
After you connect can you check the DNS tab of the Netextender client for the correct dns servers and suffix.  Also run an ipconfig /all and send the Netextender info from there.
0
 
ChiITAuthor Commented:
I just did check and when connected it lists the DNS server IP and also the servername.local, same goes for ipconfig /all.

Just did another ping check, when I ping servername.domainname.local, it resolves, if I just ping the servername it does not.

What I did notice that in the PPP adaptor Sonicwall NetExtender ipconfig, there is no default gateway listed...does it have something to do with that ?
0
 
ChiITAuthor Commented:
Hello, I found the issue. You're prompting me to look at the dns settings helped. I had one letter as caps instead of small on the dns suffix. It looks like its case sensitive.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now