Server 2012 Backup Failing

Hi there,

I have a client who has a server running Windows Server 2012 R2 Standard with Hyper-V running.
Whenever it tries to run a backup it fails with the two following errors:-

VSS writers inside virtual machine 'servername' failed to perform BackupComplete to its shadow copy (VSS snapshot) set: Catastrophic failure (0x8000FFFF). (Virtual machine ID xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

And

The backup operation that started at '‎2015‎-‎05‎-‎12T19:00:35.827000000Z' has failed because the Volume Shadow Copy Service operation to create a shadow copy of the volumes being backed up failed with following error code '0x807800A1'. Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

So far I have tried re-registering the VSS dlls, setting the Volume Shadow Copy Service to Automatic and ran an SFC scan which came back ok.

Any ideas? Your help would be much appreciated!
LVL 2
jasonuocsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve WhitcherSystems AdministratorCommented:
My first thought would be to check that the guests have the current version of integration services installed, and that the "Backup" integration service is turned on in the VM properties.  

Have you checked the event logs inside the guest?  Since it's the VSS writer in the guest that is failing, there may be a clue there.  You could also run "vssadmin list writers" at an administrative command prompt, and look for any writers listed with an error.
0
Cliff GaliherCommented:
The Hyper-v VSS writer calls the various VSS writers in each VM so the VM is in a consistent state when backed up. So the actual problem isn't in the host. As the  indicates, one of the guests is failing to run its VSS routines and the host  is simply  bubbling up the error. Look for VSS/shadow copy event errors in the guest mentioned in the error.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jasonuocsAuthor Commented:
Hi Guys,

Thanks for that info. How do I check if the integration service is up to date?
0
Steve WhitcherSystems AdministratorCommented:
Vhen at the VM console, from the Action menu you can choose to "Insert the integration services setup disk".  The setup disk should tell you if you already have the current version, or install the correct version if you don't.  

Alternatively, you can check the version from powershell on the host by running:

Get-VM | ft Name,IntegrationServicesVersion

On a Server 2012R2 host, you should have version 6.3.9600.16384


Either way, don't forget to open the settings of the VM and check which Integration Services are offered to the VM.
0
jasonuocsAuthor Commented:
Thanks guys for your help. You certainly pointed me in the right direction. It turns out after doing 93 MS Updates and restarting the failing Guest VM along with bigger Backup HDDs, the problem was solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.