IIS 7.0 Issues - sites not available after server 2008 r2 reboot

In a bit of an emergency over here - server rebooted last night and now web sites cannot be accessed internally or externally. I've rebooted the server, did an iisreset /noforce. The pages just come up as blank (I don't even get a 404).

All services are up and running. Not sure what's going on over here.
nflynn85Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John SalleSenior IT Systems EngineerCommented:
Did the Windows Firewall start again and block access?
0
nflynn85Author Commented:
Firewall is still off.
0
nflynn85Author Commented:
F12 in chrome - error shows as follows "Failed to load resource: the server responded with a status of 404 (Not Found)"

another link does not give me the same error

they both come up as blank however
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

John SalleSenior IT Systems EngineerCommented:
In IIS, are you using the default site only or do you have others? Is the site started?
0
nflynn85Author Commented:
I have multiple sites and all sites are started

see the following error external users are getting

error message
0
nflynn85Author Commented:
internal is still serving up blank pages
0
Dan McFaddenSystems EngineerCommented:
Can you post the contents (or part of) the http logs after receiving the above error?  It would be interesting to see what request is returning the 404.

Is there another server in the application loop?  Who is the SSO application trying to communicate with?

Dan
0
nflynn85Author Commented:
So I'm still working on this issue, and the issue is a Jboss issue. IIS is fine. This is the error i'm seeing. The SAS application that runs on this server uses jboss as a webserver. I've been working with support and we are looking at restoring our VMs back to about a month ago to see if the issue disappears.

My gut tells me this is related to some external account or service and I just don't know where it is or what caused it to do that

org.jboss.system.server.profileservice.ProfileServiceBootstrap] (main) Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

DEPLOYMENTS MISSING DEPENDENCIES:
  Deployment "jboss.admin:service=PluginManager" is missing the following dependencies:
    Dependency "jboss.jmx:name=Invoker,protocol=jrmp,service=proxyFactory,type=adaptor" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.jmx:name=Invoker,protocol=jrmp,service=proxyFactory,type=adaptor' **")
  Deployment "jboss.web.deployment:war=/web-console" is missing the following dependencies:
    Dependency "jboss.admin:service=PluginManager" (should be in state "Create", but is actually in state "Configured")

DEPLOYMENTS IN ERROR:
  Deployment "jboss.jmx:name=Invoker,protocol=jrmp,service=proxyFactory,type=adaptor" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.jmx:name=Invoker,protocol=jrmp,service=proxyFactory,type=adaptor' **
0
Dan McFaddenSystems EngineerCommented:
As a guess, you may find the remote server or a service account referenced in the web.config file of the server hosting the SSO application.  Only because the above error message is thrown by ASP.NET.... System.Net...

Dan
0
nflynn85Author Commented:
I was able to resolve the issue with some tech support

"During previous SAS Administration it was observed that there were some security concerns with JMX Web Console within JBoss Server. So SAS Admin removed the JMX Web Console applciation folder from JBoss Server folder by deleting it. During that process SAS Admin deleted all the relevant configuration file but he was not aware that the SAS Server instance when it was created it was based on original dependencies. One of those dependency was to initialize JMX Invoker services. By removing jmx-invoker-service.xml file it caused the error seen during JBoss startup. Placing the original jmx-invoker-service.xml file resolved the issue. Currently JMX console is still not available as application folder is removed from initialization so it should not impact anything from security perspective"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.