• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1220
  • Last Modified:

CRM 2013 - Server Side Sync Email Issue

I recently converted from using the CRM 2013 email routing to using server side synchronization. We have an on premise exchange server and it's only one organization.

All the Test & Enable Mailboxes work for everyone. People receive the test email and it is properly syncing the calendar etc.

Our processes that send email and when you try to send email directly through CRM get stuck "Pending Send" though. For example, if I'm in a case, go to activities, and try to send an email this happens. I can't seem to find anything under any Alerts etc. so I'm not sure where to look to determine what is causing this.

I did the Application Impersonation in Exchange and like I mentioned the Test & Enable works fine.
0
DaveQuance
Asked:
DaveQuance
  • 8
  • 6
2 Solutions
 
DaveQuanceAuthor Commented:
A good start would be if anyone can confirm for me with certainty that this doesn't for some reason still require the Email Router.
0
 
Feridun KadirPrincipal ConsultantCommented:
What version of Exchange do you have?

Also, is your CRM on-premise or cloud?
0
 
DaveQuanceAuthor Commented:
Both are on-premise

Exchange 2013 CU7, CRM 2013 SP1 (I think rollup 2)
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Feridun KadirPrincipal ConsultantCommented:
Yes, that combination should work. Review the email server profile and look at the authentication settings for the outgoing mail server.

Depending on your selections, it might be necessary for each user to configure settings on the Email tab of Personal Options.
0
 
DaveQuanceAuthor Commented:
Attached is a copy of the Email Profile settings (there is only the one profile), the Email Configuration Settings (under System Settings), an example mailbox I'm testing with, and the Personal Options for the example mailbox.

As the mailbox image shows, the test & enable was successful for incoming, outgoing, and appointments etc. I have the setting not requiring approval of emails but I approved all emails anyway.

Can you see anything I missed? When I open an email that was supposed to go out at the top it says:

"This message has not yet been submitted for delivery. For more information, see help."

And at the bottom near Activity Status it says "Pending Send"

Neither are clickable to get more info, not sure where the help is it's referring to.
EmailProfile.jpg
System-EmailConfigurationSettings.jpg
UserMailbox.jpg
PersonalOptions.jpg
0
 
Feridun KadirPrincipal ConsultantCommented:
One quick thing to check, is the Microsoft CRM Asynchronous Service running?  That is responsible for delivering emails using Server Side Synchronization
0
 
DaveQuanceAuthor Commented:
Yes, it's running. I have two servers but it is running on both. They use Windows NLB on the front-end.

When I do the Test & Enable it sends an email to that user and impersonates them. So in the example user jdoe, jdoe receives the email during that and it shows as being from jdoe.

Note: And it is the service account for Microsoft Dynamics CRM Asynchronous Processing Service (MSCRMAsyncService) that was given the ApplicationImpersonation in Exchange:

Get-ManagementRoleAssignment
Name                           Role                        RoleAssigneeName            RoleAssigneeType            AssignmentMethod            EffectiveUserName
----                           ----                        ----------------            ----------------            ----------------            -----------------
CRM ExServiceAcc               ApplicationImpersonation    Service CRM APS             User                        Direct                      Service CRM APS
0
 
DaveQuanceAuthor Commented:
I may have inadvertently solved the problem. Sadly I never thought to restart services.

I decided to drain one of the two servers, stop all of it's services and test with one server at a time. It failed. Upon starting the services again on the one I took off I suddenly got a bunch of emails that hadn't gone out. Testing further but.... yeah
0
 
Feridun KadirPrincipal ConsultantCommented:
Great.  The old switch it off and on again!

Though for the Exchange impersonation I would have expected that it is the account on the server profile that needs applicationimpersonation in Exchange. Perhaps giving it to the async service also works.
0
 
DaveQuanceAuthor Commented:
I had read that the async was the one that processed the email and was the one that needed it. So that was the account I used for the profile and the impersonation. Is that a bad practice?
0
 
Feridun KadirPrincipal ConsultantCommented:
Not sure if it is bad practice but it is not what is described here:
https://technet.microsoft.com/en-us/library/b4a7e72b-df4f-42d8-a91d-c69cc52ff138#BKMK_CreateProfile

Search for this text, Credentials Specified in Email Server Profile, on the page.
0
 
DaveQuanceAuthor Commented:
Hmm based on that I should have just selected the Windows integrated Authentication since I gave the impersonation to the service account. Thank you.

"Windows Integrated Authentication. This option applies only to Exchange and SMTP email server types. If you select this option, the credentials with which the Microsoft Dynamics CRM Asynchronous Service has been configured will be used."
0
 
Feridun KadirPrincipal ConsultantCommented:
Indeed, yes that would be appear to be the case.
0
 
DaveQuanceAuthor Commented:
After more testing I confirmed it's all working fine now.

feridun, thank you for your time in helping me to go over my configuration, validate it, and help keep me from looking in all the wrong places (I spend 3 hours on this yesterday and I'm at 1-2 today).

Note: If anyone runs into this, I was using the CRM Email Router and I changed my configuration to Server Side Synchronization. Test & Enable Mailbox emails worked but workflow ones in cases and processes did not. Simply restarting the services did the trick.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now