New WSUS server, same name as the old one - no clients?

Small business, retiring our old WSUS server which was ws2003.  I made a new 2012 R2 server and named it the same as the old server, for reasons unrelated to WSUS (LOB app that makes it easier this way).  Of course the old server was renamed and given a new IP first.  The new server has the same IP as the old server had, so DNS is unchanged.

I installed the WSUS role and related features (IIS etc).  Because the old server was pretty crudded up and the cleanup wizard could never complete even after running for days, I decided to not migrate but just start over, fresh.  I configured the new one from scratch (products, auto-approvals etc) and completed a first sync with MS as the upstream. It's configured the same as the old server.

The GPO that points clients to WSUS still has the same URLs for WUServer and WUStatusServer, but no clients are showing up.  How do I get clients to check in with the new server?  Clients must be using more than just a URL, like is there a GUID or certificate or such?  We are just using http for now so I don't think it's SSL.  Windows firewall on the WSUS server has the right entries I think.

Grateful for any advice
VSI-OAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
How were the clients managed, by GPO or by registry?

Look in c:\windows\windowsupdate.log to see what system it is connecting to and what if any issues it has.

Your issue might be that the old wsus was setup on 8350 port or 80 while the current one set on a different port such that it can not be contacted.

You would need to use wsusutil to setup the IIS site on the correct port matching the GPO or adjust the GPO intranet URL for wsus.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
don't forget in the gpo to add the port 8530
0
VSI-OAuthor Commented:
Yeah it was the port not added in the GPO.  Thanks to both of you.
David, I'm giving arnold "Best Solution" just because I saw his, then went and fixed it based on that.  Yours was just as good just not quick enough!

Cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.