HP zero clients requiring DOMAINNAME\username to log on

We are having an interesting issue with our HP zero clients.

In their setting they are configured to log onto our terminal servers through RDP. The domain is configured in the settings as well. However when they click on the connection they want to use it will connect them directly to the terminal server but instead of the domain showing up it will have the actual hostname. Not a huge deal for a sys admin but you can probably imagine that this is a nightmare for users.  To get them logged in you have to type domain\username and then the password. I have updated the zero clients to the most recent firmware and the issue is still going on.

Any ideas are greatly appreciated.

Josef
LVL 3
Josef Al-ChacarSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jian An LimSolutions ArchitectCommented:
if you want easier access for the end user, then you need to drop the terminal server encryption from high (default on windows 2008) to low and/or Security layer to low

it will revert back to the previous experience where connect directly to terminal server and login from there.

On windows 2008, by default is a POP up windows before you got into the login screen.




https://technet.microsoft.com/en-us/library/cc781085%28v=ws.10%29.aspx
0
Dirk KotteSECommented:
last seen with win 2003.
if the administrator log on at the local console with local administrator account the hostname is written as "default domain name" to the registry. These is the default Domainname suggested at the next logons.

The key should exist at "HLM/Software/Microsoft/Windows NT/CurrentVersion/Winlogon".
Check the key and correct them if necessary. i use a GPO to overwrite this key in the past.
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
@limjianan: We are running Windows server 2008 r2. I apologize for not specifying. I do not see the option for TS in GPO.

@dkotte: What would be the name of the key?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Jian An LimSolutions ArchitectCommented:
hi,

yup. it is the same on windows just different name

On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration.
Under Connections, right-click the name of the connection, and then click Properties.
In the Properties dialog box for the connection, on the General tab, select the server authentication and encryption settings that are appropriate for your environment, based on your security requirements and the level of security that your client computers can support.*** you need to change it from high to low, and etc ... ***



https://technet.microsoft.com/en-us/library/cc770833.aspx
0
Dirk KotteSECommented:
keyneme is "DefaultDomainName"
https://technet.microsoft.com/en-gb/library/cc939708.aspx

if this don't work check these threat.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_26352492.html
but i don't test this.
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
@dkotte: I did this and it's still happening on some of the thin clients.

@limjianan: I do not see how this will help. They are able to log in it is just asking me to put in the domain name before the username even though it's entered into the thin client settings.

Josef
0
Jian An LimSolutions ArchitectCommented:
can you have a screenshot of the thin client to explain where you get put in the login name?
is it happen at the thin client side, or after enter to the RDP login screen then prompt?

my method will let the thin client enter the RDP login screen (and usually RDP login screen by default will have the domain written there)
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
I have attached a screenshot. It's generic but this is where we are entering the username/PW and the domain is already set in the settings.

Josef
0
Jian An LimSolutions ArchitectCommented:
i did not see the screenshot?
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
Sorry about that. Forgot to hit upload.
ZeroClientLogin.png
0
Dirk KotteSECommented:
can you post a screenshot with the hostname displayed also?
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
No i do not want to put a HN on a public forum. This is for security purposes.
0
Jian An LimSolutions ArchitectCommented:
how i totally make sense.
My previous comment is on RDP not on the HP Zero client.
so please ignore all comment i made.

I have dig through the HP zero clients.
do you have HP Broadcast Server
Have you update your registry key in persistent profile ?


http://www.ingmarverheij.com/hp-smart-zero-client-a-first-impression/
http://h20565.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c03466126
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Josef Al-ChacarSystems AdministratorAuthor Commented:
Thanks for looking into it.

Yes i updated all those registry keys on all of our terminal servers.

We use HP device manager.

Josef
0
Josef Al-ChacarSystems AdministratorAuthor Commented:
I resolved the issue i just turned off the services for the HP device manager.

Josef
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.