error joining 2nd server to our domain

Hello,

We have a single windows 2012 R2 which we have configured into 2 virtual machines using Hyper-V,

We can ping each of the servers OK.

We created a local domain called companyname.co.uk

We installed DNS & DHCP services, and all looked OK, however when we try to add the second server to the domain, we get the "Welcome to the new domain" notice, which seems to confirm that all is well, but a couple of minutes later we are told :-

" changing the primary domain DNS name of this computer to "" failed. the name will remain companyname.co.uk

the error was
the specified domain either does not exist or could not be found.~

Once restarted, the server still reports that the server IS part of the domain, but we find no new entries in the DNS listings, and we cannot browse the network.

We CAN connect to the server using \\servername

When we ran DCPROMO we did receive an error ... A delegation for the DNS server cannot be created because the authoritative parent zone cannot be found...

Having looked at this, I seem to find that as this is our only DC, we can ignore the message?? Is that the case?

I am pretty lost now, so would welcome any assistance in trying to resolve this issue.

One other thing, when we initially created the DNS, there did not seem to be any entries for the actual domain controller, so had to make them manually.

Do you think this is related to DNS?
LVL 1
nigelbeatsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nigelbeatsonAuthor Commented:
|I thought I should mention that at this stage this is not a live installation, so can remove and re install anything which you think appropriate.

Thanks
Will SzymkowskiSenior Solution ArchitectCommented:
The first server that you setup is it a DC? You need to make sure that you are using Active Directory Integrated DNS.

Will.
nigelbeatsonAuthor Commented:
I just selected DNS from the list of roles. is there something significant that I missed?

how can I tell which is installed and if it is not integrated, can I remove it and re install the correct version.

many thanks
SD-WAN: Making It Work for You

As bandwidth requirements and Internet costs grow, businesses naturally want to manage budgets by reducing reliance on their most expensive connection types. Learn more about how to make SD-WAN work for your business in our on-demand webinar!

nigelbeatsonAuthor Commented:
sorry - yes it is a dc.
Will SzymkowskiSenior Solution ArchitectCommented:
Once you have configured your initial DC and your internal domain name, all of your other servers should be able to join the domain without any issues.

Will.
Lee W, MVPTechnology and Business Process AdvisorCommented:
I would suggest you post screen shots of the TCP/IP properties listing IP addresses and DNS.  It can help us pinpoint what you may have done wrong.
nigelbeatsonAuthor Commented:
I seem to recall when I added the role of dc, I got an error that it could not find a suitable DNS, so I installed that first. I then installed the ad role.

I don't recall seeing anything about integrated DNS.

should I have selected them both at the same time?

does it automatically install none integrated DNS if ad is not present at the time of installation? is it possible to tell which version is installed AFTER installation? if so how?

I will add the info requested as soon as I get back to this site.

many thanks
nigelbeatsonAuthor Commented:
Having looked at the "Type Setting" in the DNS domain forward lookup properties, I can confirm that it is configured (and already was) as  "integrated".

I removed the AD and DNS roles and started again.

I not that there are constant claims stating :- A delegation for the DNS server cannot be created because the authoritative parent zone cannot be found or does not run windows.

It states this at the time of installation, during the pre requisite check and also in the BPA results.

Is this normal?? This is the only DC, and is totally stand alone at the moment. ie we are just preparing it.
nigelbeatsonAuthor Commented:
I am not sure what the problem was, but removing the roles and re adding them has solved one of our problem.

The second virtual server now adds to the domain without error.

We still cannot browse the network from the 2 servers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nigelbeatsonAuthor Commented:
Thanks to all who tried to help, but I found the solution myself.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.