Possible corrupted files from synology NAS unit? Suddenly unable to authenicate with vm Windows Exchange 2003 server and get randomly denied access on terminal server login.

*As of yesterday, we are unable to retrieve and send email on any user account through remote terminal sessions with exchange server 2003 accounts. (OWA still works.)

Sorry for the very vague description, but that's the 'main' issue,
Our rack setup:
 
HP Proliant DL360p (Gen 8) with vmWare ESXi 5.1
NAS Synology DS1813+ (recently upgraded to 5.1.5022)
with 8 x 3TB Red iSCSI drives in a SHR array.
Cisco SG200-26p switch

   Early March, we upgraded our Synology box to the 5.x series with no issues.
On March 27th, our Synology box auto-updated to the newer version and nothings been right since.
We started experiencing random loss of connection to the Synology NAS which we used as the only data store for all of our vms and backups.

  From a terminal session (and also vmsphere), it would simply become completely unresponsive and give no warning or indication that it lost connection to the NAS. What made the situation worse was that since the synology box lost its network connection, we couldn't remote in and check what was going in. After a few sleepless nights, thankfully on the weekend, we narrowed down a relation between starting large backup files on the NAS to being a cause of the lost connectivity. So after reading about all the bad experiences in forums with the implications of updating to the newest 5.1.x, we decided on stopping any large backups from running (strongly against it, but it was the only way it stayed up).

   Fast forward to yesterday, and our exchange server 2003 vm ( also running Active Directory and a domain controller), seemed to lock up. On a reboot, it started looping right after getting past POST, a few seconds into the windows 2003 server splash screen. So we tried to boot it up off of a repair disc and run a check disk, which fixed it enough to come back up but with log errors saying that there were still corrupt system files. Now, it's acting as if the users can't authenticate with the Exchange server on the Domain. And it also is randomly not letting users connect into the terminal server through rdp, throwing an  "Access is Denied" error.shows up randomly on login in screen and prevents login.
   We have spent the last 24+ hours reading tons of other forumns, synology and vmware support pages,  and trying every reasonable suggestion we have come across, but with no luck. So I have a feeling it has to do with the synology update and dropped network issues corrupting vm system files that have led to this somehow. So any suggestions or directions for narrowing the issue would be appreciated.
MagicalComputingSolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

egarrisonCEO / CTOCommented:
I have seen that login screen before when the C: on windows is full.  Do a \\ServerName\c$ and connect to it. Try deleting some files.  Be very Careful about reboots right now.  I have seen VM's run when while the iSCSI under them is crashed or lost mounting.  Then when you reboot VMware or the machine, nothing is there.  I would bet that you have a bad drive.  It may not have gone into error state yet and started rebuilding. SATA drives don't give as much warning as SAS or FC drives.
0
MagicalComputingSolutionsAuthor Commented:
Found that if we stopped our backup software or basically any big file transfer, the synology box would stay running. We went without a solid backup until synology released a new update and switched to that. It's been stable ever since but what a headache from the bad update.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MagicalComputingSolutionsAuthor Commented:
We never really solved exactly what caused the issue but only found that if we turned off the services we didn't absolutely need to stay running (although risky), it wouldn't crash and something in the new update must of corrected these issues.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.