Ajax request error: Not Found (404)

When I load my page into my browser I get the message:
The page at avatarglobaltravel.com says:
Ajax request error: Not Found (404)

I'm using Chrome to view it.

The error messages are not very helpful. Can anyone tell me what I'm doing wrong?
mmathis32Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
You have quite few files that are 404 not Found.  Attached are the headers from loading your page.  Most of the files are supposed to be in http://avatarglobaltravel.com/assets_global/ .
avatarglobal-headers.txt
0
mmathis32Author Commented:
How did you get that file?
0
Dave BaldwinFixer of ProblemsCommented:
I have a Firefox Add-on called LiveHTTP headers.  You can get it here https://addons.mozilla.org/en-US/firefox/addon/live-http-headers/   There are other programs that can capture the headers too.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mmathis32Author Commented:
I copied the files that were missing and it still says the same thing.
0
mmathis32Author Commented:
How do I get the headers file. I've downloaded the link you posted.
0
Dave BaldwinFixer of ProblemsCommented:
Did you install LiveHTTP Headers in Firefox?  If you did, you should see it on the Tools menu.  Go to the page you want to get the headers for.  Then click on Live HTTP Headers on the Tools menu.  Make sure the 'Capture' box is checked and then press Ctrl-F5 to do a complete reload of the page.  Then you can save the data to a file so you can inspect it.
0
Dave BaldwinFixer of ProblemsCommented:
You did clear up some of the 404's but not all of them.  You may need to disable the external javascripts one by one until the message disappears.  Start with the ad tracking scripts.
0
mmathis32Author Commented:
I went to settings, and it shows options, add-ons and developer. Under options, it says general, tabs, search,content, applications, privacy, security, sync, and advanced. I don't see anything in any of these menus that would help.
Next I go to Options and this gives general, data choices, network, update, and certificates.  Again I don't see anything that would help.

Next I go to Add Ons Manager. Here I see get add-ons which I've already done, extensions, appearance, plugins and services.
When I click on Extensions, it gives me Live HTTP headers and it says options, disable and remove. I click on options. IT gives me headers, generator, config and about. But under headers, it populates some info but doesn't allow me to select what url I want to capture. How do I specify what url I want to capture.
0
mmathis32Author Commented:
How do I disable the external tracking scripts one by one?
0
Mukesh YadavFull Stack DeveloperCommented:
Can you share the code?
0
mmathis32Author Commented:
sure!
index.html
0
Dave BaldwinFixer of ProblemsCommented:
Don't go to 'settings', go to Live HTTP Headers on the Tools dropdown menu.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mmathis32Author Commented:
Now it only shows 2 files both of which exist.
0
Dave BaldwinFixer of ProblemsCommented:
Then you Should check permissions on those files.  If they are not accessible for some reason, they will be reported as 404.
0
mmathis32Author Commented:
I've gotten rid of all the files it couldn't find. Now the only files that it reports is shown below.
0
mmathis32Author Commented:
this doesn't give any files that it's looking for.
0
mmathis32Author Commented:
I didn't change permissions on the files that it couldn't find. Now it says only one file as shown below.
headers2
0
mmathis32Author Commented:
IT only shows an upgrade to firefox...
0
Dave BaldwinFixer of ProblemsCommented:
How do I disable the external tracking scripts one by one?
Make a backup copy of the page.  Start from the bottom and start deleting the scripts until the error message stops showing up.
0
mmathis32Author Commented:
Why is it showing an upgrade to firefox?
0
Dave BaldwinFixer of ProblemsCommented:
Why not?  Firefox automatically fetches it upgrades.
0
mmathis32Author Commented:
I changed the permissions on the files that come up to 644 and they still come up.
0
mmathis32Author Commented:
thanks!
0
Dave BaldwinFixer of ProblemsCommented:
You're welcome, glad to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
AJAX

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.