Can't access Win 8.1 machine on LAN from Win 7 or Vista machines

I have a LAN at home with one Win 8.1 machine, a couple of Win 7 machines and a Vista virtual machine hosted by the Win 8.1 machine. The Win 8.1 machine can access network shares on all the other machines but none of them can access any shares on the Win 8.1 machine. What do I need to do?
LVL 1
BlearyEyeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Anthony CarterCommented:
Go to Network and Connection Sharing and verify the network connection is set to "Private network".

Click on Advanced in here and check that network discovery and file and printer sharing is enabled for the private network.

Lastly, check windows firewall (or whichever firewall you have) and make sure that File and Printer sharing for the private network is enabled.

A good article on this is: http://windows.microsoft.com/en-us/windows-vista/enable-file-and-printer-sharing
0
JohnBusiness Consultant (Owner)Commented:
Also make sure:

1. You enumerate the other usernames and passwords on the Windows 8.1 machine you wish to access.

2. Make sure Password Protected sharing is ON and HomeGroup is OFF. Vista does not support home group.

Please see my article on Folder sharing for modern machines.

http://www.experts-exchange.com/articles/16639/Folder-sharing-on-modern-machines.html
0
rindiCommented:
Make sure you have created the user accounts on the you want to logon to it's shares with on the 8.x PC. Also make sure those accounts are allowed to access the shares, and that they are also included in the ntfs permissions.

If you used the m$ account on the Win8.x PC, and you want to connect using that account, remember that it isn't just "UserName", but rather "UserName@Hotmail.com" (or similar).
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

BlearyEyeAuthor Commented:
Connection "Network 7" is public and I can't find how to make it private in Win 8.1. Network and Sharing CenterI've checked Settings -> Network and selected the WiFi connection, but there are no properties to change.WiFi PropertyPerhaps the fact that I'm sharing the Internet connections with Hyper-V is confusing things.
0
JohnBusiness Consultant (Owner)Commented:
Delete (Forget)  the network profile in Windows 8 and then restart the computer. On making a new profile make it private (not public) at that time. Windows 8 made that one difficult.
0
Anthony CarterCommented:
In Windows 8.1:

1) Open the charms bar and click on settings. (Win + I to open settings flyout shortcut).
2) In Networksflyout, right click the connection in question.
3) Select "Turn Sharing on or off"
4) Click Yes to turn on sharing

Good link with pictures: http://www.eightforums.com/tutorials/9837-network-location-set-private-public-windows-8-a.html
0
BlearyEyeAuthor Commented:
Anthony: The option to turn sharing on or off doesn't appear. Only show usage etc. Am trying John's suggestion next.
0
Anthony CarterCommented:
Hi,

Try this:

From: http://www.eightforums.com/network-sharing/33735-8-1-change-nework-profile-public-private.html

From what I can tell you just go to network section through the charms bar, Settings>Change PC Settings>Network, then click on the network you need to change "first picture".

Then just turn off or on the sharing option switch at the top of the page which should change from Public to Private network "second picture". This seems to be a completely different procedure compared to Windows 8.
0
BlearyEyeAuthor Commented:
Still no joy. All I get is Data usage (see second image in my previous post, http://www.experts-exchange.com/Networking/Windows_Networking/Q_28674857.html#a40783558). UAC is set correctly (to default).

John: I forgot the network, rebooted, and reconnected. The question about public vs private did not come up.

I'm still inclined to think that Hyper-V is part of the problem.
0
Anthony CarterCommented:
You may have to go through the registry hack part of http://www.itwriting.com/blog/7682-how-to-change-a-network-from-public-to-private-in-windows-8-1.html

It seems there might be an issue with removing wireless and/or changing wireless connections.
0
BlearyEyeAuthor Commented:
Actually, I've already done that once. Sign. I guess I can try again but I'm doubtful.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Open Windows Explorer and click on the Network icon in the left hand column. You should get prompted to enable Network Discovery. Enable it.

That should allow inbound browsing.

You could also forget the current network. When initially prompted the Public option was chosen thus the current status for this network. Choose Work/Home to allow some sharing out of the box.
0
BlearyEyeAuthor Commented:
FYI, a family member is in the hospital and I've been fully tied up. it will be a while before I can get back to this.
0
BlearyEyeAuthor Commented:
Well, this is interesting. Since I last commented, I've done nothing on this problem but now the  WiFi connection is set to Local and sharing is suddenly working. The only thing that might have affected this is that I did a reboot of the Win 8.1 PC. It was not, however, the first I've done since I started this thread.

So now things are working: Win 7 can access the Win 8.1 PC as can the virtual Vista machine. I appreciate the effort. Most of the suggestions were credible so I'll assign points and close the question.

Thanks.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BlearyEyeAuthor Commented:
Included my own comment as the "answer" since things just started working ...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.