proftpd-1.3.5 problem in linux RHEL 7

thanks for your advise, I have another issue when installing proftpd proftpd-1.3.5, I cant find the proftpd.conf any idea ?


 proftpd:[root@localhost proftpd-1.3.5]# whereis proftpd
 proftpd:[root@localhost proftpd-1.3.5]#


ftp
piaakitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

manuverhaegenSystem & Storage AdminCommented:
Hi,

Install ProFTPD server

Type the following command as root user:
# yum install proftpd

Start ProFTPD when the system reboot:
# chkconfig --level 3 proftpd on

To start proftpd ftp service, enter:
# service proftpd start

To Stop proftpd ftp server, enter:
# service proftpd stop

To restart proftpd ftp service, enter:
# service proftpd restart

To reload the configuration file, enter:
# service proftpd reload

/etc/proftpd.conf - Proftpd configuration file

The default configuration file is located at /etc/proftpd.conf. To edit the configuration file, enter:
# vim /etc/proftpd.conf

Checking the syntax of the configuration file
# proftpd -t6
arnoldCommented:
Since you compiled from source without seemingly making change to where the config goes, it is likely in /usr/local/ as the base prefix where sbin, bin and etc within that prefix is where you would find the various command.
In future when you install from source, ./configure --help includes what options you can change/adjust
--sysconfig
Etc.

strings /usr/local/sbin/proftpd | grep -I 'etc'

Should confirm the location where the config is being looked for.  Within the source you may have a proftpd.conf.in or something like that that is the base config and you need to run make with an option.  Look through the Makefile if it has an option that builds/sets up proftpd.conf.
gheistCommented:
Dump what you compiled from source.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

piaakitAuthor Commented:
[root@localhost ~]# strings /usr/local/sbin/proftpd | grep -I 'etc'
strings: '/usr/local/sbin/proftpd': No such file


Does it means the proftd.conf is located in below path ?

proftpd:[root@localhost /]# locate proftpd.conf
/root/Downloads/proftpd-1.3.5/src/proftpd.conf.5
/root/Downloads/proftpd-1.3.5/src/proftpd.conf.5.in


at first I was using this command,

./configure --with-modules=mod_sql:mod_sql_mysql:mod_quotatab:mod_quotatab_sql --with-libraries=/usr/lib/mysql --with-includes=/usr/include/MySQL

& then this

# ./configure --prefix=/usr --with-includes=/usr/local/ssl/include --with-libraries=/usr/local/ssl/lib --enable-openssl --with-modules=mod_sftp --enable-dso
gheistCommented:
Can you stop trying to damage your system with non-professional not packaged unsupportable side-build of proftpd?

Last command of yours  (if followed up by make install) will damage RPM packaging for no return, make your system unsupported by redhat, and lead to reinstall and related data loss.

PLEASE INSTALL PROFTPD RPM FROM FEDORA EPEL https://fedoraproject.org/wiki/EPEL

and

NEVER EVER RUN ./configure AS ROOT
arnoldCommented:
Which instance did you install?
--sysconfigdir=/etc
Will set the location for config in etc.
When you ran configure, did it complete successfully without any errors?
When you run make, did you get any errors? Make install will have nothing to install if an error in the prior preceded it.

One option as gheist pointed out is to get the proftp RPM.

Before you can trouble shoot a config, you first have to make sure the version you are compiling is compiled without error and is installed.

find /root/Downloads/proftpd-1.3.5/ -name "proftpd"
See if the item is actually compiled and run strings on it.
gheistCommented:
Preferably not overwriting authentic & supported files in /usr/ and /etc/ ;)
piaakitAuthor Commented:
I don't receive any errors at all after I run make  & make install, and sorry I,m new in Linux I just run the ./configure from what I have found from the internet, any correct documentation can show me what I should use for command ./configure before using make && make install , thanks for all your reply !!


where I can find proftpd from below link

PLEASE INSTALL PROFTPD RPM FROM FEDORA EPEL https://fedoraproject.org/wiki/EPEL
arnoldCommented:
You would add  the repository,
From the link gheist provided:

NOTE for CentOS users
You can install EPEL by running yum install epel-release. The package is included in the CentOS Extras repository, enabled by default.
Then run yum install proftpd

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
After running "make install" you now need to clean up all the manual build trails from system directories and install clean RPM.
piaakitAuthor Commented:
[root@localhost proftpd-1.3.5]# find /root/Downloads/proftpd-1.3.5/ -name "proftpd"
[root@localhost proftpd-1.3.5]#

my system is not registered to Red Hat Subscription Management yet, not able to use yum right now
arnoldCommented:
You can add the repo.
On the link, there is in middle of the page where you can choose which version you have to navigate through the packages

Epel7 x86_64
Epel 6

Etc.

You had an error when you tried to configure, which would prevent the make and subsequent the make install.
piaakitAuthor Commented:
Is this below in red ?

1

which one ? sorry for trouble, and thanks a lot for you assist !!!

2
gheistCommented:
You must reinstall system, register it with redhat, as proftpd install pulls couple of dependencies from redhat.
Why dont you try out on absolutely free CentOS instead and use expensive RedHat once you build enough muscle to handle it?

You must add repository to get security updates automatically.
gheistCommented:
Hello? How do you navigate website?

Please follow repo install instructions in front page (after cleaning system from mess you left building your own proftpd, preferably by clean reinstall.
piaakitAuthor Commented:
Noted, I might build a CentOS instead, and thanks a lots for all your support !!
arnoldCommented:
Atop the screen you posted the image there are a-z, select P and you will see all the available packages starting with p and proftpd.
gheistCommented:
It is not what you migh build.
Your handling irreversibly damaged the system. You need to reinstall and properly register it's redhat subscription.
Then you can have proftpd installed without glitch.
piaakitAuthor Commented:
you I found it, now I,m looking for 3 dependencies in order to install proftpd, I found 2 and installed successfully, only for below need to be installed, Thanks Arnold !!! you helped a lots !!

 libmemcachedutil.so.2()(64bit) is needed by proftpd-1.3.5-5.el7.x86_64
arnoldCommented:
Whenever you look for libs, it is in the form lib<packagename>.so


memcache I think us the package/dependency you need.
arnoldCommented:
http://libmemcached.org/libMemcached.html

Check the DVD from which you installed rhel, some packages should be there.

There is often issues with using other repositories.

I think you can add the role repository to your yum search to have this process ....
piaakitAuthor Commented:
Noted with thanks your info is very useful !!
piaakitAuthor Commented:
One more issue once I have installed proftp , I want to open the firewall to open port 21 , but once I have turned on the firewall all of my client pc not able to access the Internet, any way I can turn on the firewall while all the client pc could access internet ? In RHEL 6 I could open the firewall to do port forward in GUI, anything I need to do ?
arnoldCommented:
The difficulty in continuing answering questions not related to the topic at hand is that one needs to have a full picture/detail to answer the most recent one.
I.e what is the setup.

When you enable the firewall, you have to make sure that all services on which your LAN systems depend are open as well.  Your likely issue is that you need to open port 53 for both udp and TCP.
arnoldCommented:
Fwbuilder is a GUI interface to iptables.  Which firewall do you have installed in rhel, firewalld or iptables?
System-config-firewall might be what you can use.

My suggestion you should open a separate question to deal with the firewall where you describe your setup, what services your RHEL system provides DHCP, DNS, mail, web, proxy, FTP, etc.
piaakitAuthor Commented:
Noted I will close this one and open new topic thanks !
gheistCommented:
memcached is the component that you can get when your system is subscribed to redhat or satellite.
there is no "i found it on the internet" dependencies, you must apply like 10 security patches on top of 7U1 DVD install
piaakitAuthor Commented:
Noted with thanks gheist
gheistCommented:
Or when you install CentOS you have all packages available....
Really dont waste subscription on learning experiments.
piaakitAuthor Commented:
Thanks gheist, wanna know that is below like workabe to crack my RHEL 7 to become yum server, i will not going to do it just wondering whether it will really work ?

https://www.youtube.com/watch?v=N8kVMgDPBKY
gheistCommented:
No, that is breach of contract in eyes of redhat licence, and pretty much waste of time when CentOS, Oracle Linux and Scientific Linux offer 0.99:0.99 clone systems for free.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.