Apple Wireless Keyboard question


i've got a new apple wireless keyboard, it is a QWERTY keyboard, the only issue i'm facing is when you get into the session login on OS X, it doesn't type qwerty but azerty so for example if my session password is : david I have to type : dqvid so the system can accept it, once I login everything changes to qwerty and i use it fine.... how to fix this issue and thank you
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
You can change this through system preferences > Users&Groups > Click Login Options and enable "Show Input menu in login window" ... (might need to click the lock to enable this feature)

Or how Apple explains it:

- From the Apple menu, choose System Preferences.
- Click Users & Groups to display the pane (or choose User & Groups from the View menu).
If the lock icon in the lower-left corner of the window is closed, click it, then enter the name and password of an administrator to unlock it.
- Click Login Options.
- Select the "Show Input menu in login window" checkbox.
- From the Apple menu, choose Log Out.
- At the login window, click the Input menu (shows the name of the currently selected input source next to a keyboard icon) in the upper-right corner of the screen, then select the desired input source or keyboard layout. If you don't see the input source you are looking for, move the pointer over Other Input Sources, then select the input source from the complete list that appears.
adra750Author Commented:
that worked great but how to hardcode it for U.S input instead of french?
Zephyr ICTCloud ArchitectCommented:
Well, it isn't without risk, you can overwrite the plist file to remove the non-used layouts.
It should be something like this:

1. Login to your account.
2. Open the Terminal app.
3. sudo cp ~/Library/Preferences/ /Library/Preferences/
4. sudo chmod 644 /Library/Preferences/
5. reboot, and pray ;-)

Open in new window

Now, this means there's not unwanted layouts there though ... Let's first see what this does.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Virus Depot: Cyber Crime Becomes Big Business

The rising threat of malware-as-a-service is not one to be overlooked. Malware-as-a-service is growing and easily purchased from a full-service cyber-criminal store in a “Virus Depot” fashion. View our webinar recording to learn how to best defend against these attacks!

adra750Author Commented:
my mac doesn't want to boot, i'm crying

hehehe no it worked fine, even if that happened i have time machine backup drive.

so now the keyboard point to the U.S input
Zephyr ICTCloud ArchitectCommented:
Djeezes ... The first sentence got to me for a second :-)

Great, so that worked as should ... Awesome, only tested that out once so glad it seems to still work.
adra750Author Commented:
thank you very much
Zephyr ICTCloud ArchitectCommented:
No problem, glad to help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.