Disable Auto Discover in OUtlook 2010 to eliminate certificate mismatch error

I keep getting a certificate mismatch error when Opening Outlook 2010. Is there a way to disable autodiscover so I don't get that message. My domain is a .local domain. I have a certificate for my internet based clients so they have no issues. I can't rename my domain since Exchange 2010 doesnt' support it. I don't need autodiscover since I manually configure my clients. I just want to permanently turn it off.
P HurdleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shweta GoelCommented:
Hi,

To disable an auto discover, you can use these regkeys: -

•      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover\ExcludeSCPLookup = 1

•      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover\ExcludeHttpRedirect= 1

•HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover\ExcludeHttpsAutodisoverDomain = 1

•      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover\ExcludeHttpsRootDomain = 1

•      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover\ExcludeSrvRecord = 1

I also try all these on my system and it work. I hope it will also prove helpful for you.

Regards
0
P HurdleAuthor Commented:
I tried this and still get the same message. Please help!
0
MAS (MVE)EE Solution GuideCommented:
Please try to redirect the autodiscover requests
http://erkansezgin.blogspot.com/2008/09/how-to-use-one-certificate-for.html
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Shweta GoelCommented:
Hi,

Place a DENY on the SCP objects in AD and just not publish the DNS records until the migration coexistence is complete.

You can use ADSIEdit for that.

Regards
0
P HurdleAuthor Commented:
I can't understand why these registry changes don't work for me. Does it only work sometimes? Please help!!!
0
P HurdleAuthor Commented:
I ended up paying Microsoft to resolve the issue for me.

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MAS (MVE)EE Solution GuideCommented:
I appreciate if you post what you did and select that as answer.
You can click on object and re-award
0
P HurdleAuthor Commented:
I ended up calling Microsoft to resolve the issue. Not sure if this is really a solution. Otherwise, please close the case.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.