How do I repair a Win7 registry key whose values I cannot display or delete?

I prepared to upgrade the Wacom Intuos Pro tablet by uninstalling the existing driver per Wacom's support. The uninstall process hung the computer for over an hour. I forced a power-off per Wacom's direction. Retried uninstall and similar behavior. Wacom can't/won't help and I can't get beyond first level support.

All this left me with a screwed up registry entry key "HKEY_CLASSES_ROOT\Wow6432Node\AppID\npWacomTabletPlugin.dll". If I go to the key I get an "Error Opening Key": "npWacomTabletPlugin.dll cannot be opened. An error is preventing this key from being opened. Details: The system cannot find the file specified." If I try to look at the permissions for the key I get "The requested security information is either unavailable or can't be displayed." If I try to export the key I get "Export Registry File": "The selected branch does not exist. Make sure the the correct path is given". If I try to delete the key I get "Error Deleting Key": "Cannot delete npWacomTabletPlugin.dll: Error while deleting key." I tried Sysinternals' RegDelNull. It did not show the key as having nulls.

I wasn't thinking while waiting for Wacom's response and let any Restore Point slip off the end.

I can manually recreate the values in the key if I can just delete/re-add it. Any ideas how to do that?

Thanks,

Joe M

The Win7 64-bit computer works except for the tablet. "Programs and Features" shows the "Wacom Tablet" v6.3.7-6, the "Web Tablet FB Plugin 64 bit" v2.1.0.3 and also the 32-bit plugin.
JoeM21Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jackie ManIT ManagerCommented:
have you tried system restore to go back to the time before the uninstall of the Wacom software/driver?
JoeM21Author Commented:
I am not able to do a system restore because the Restore Points from before the uninstallation have been pushed out of the cache.
Spike99On-Site IT TechnicianCommented:
Have you tried doing a repair install of the original Wacom tablet driver? that might restore the registry entry & the missing file so you can uninstall it.

Here is the download page for Wacom legacy drivers:
http://us.wacom.com/en/support/legacy-drivers/
Adam LeinssServer SpecialistCommented:
Try running regedit under the SYSTEM account.  Download the Sysinternals suite: https://technet.microsoft.com/en-us/sysinternals/bb842062.aspx.  Extract to folder, run Command Prompt as elevated user (basically, right click and pick Run As Administrator), navigate to that folder within the command console, then type psexec -i -s regedit.exe and see if you can get into the key now.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JoeM21Author Commented:
Thanks Adam. That did the trick.

When I ran regedit under the SYSTEM account, the key did not show up. I manually added the key and then added the one value. Now it is readable via a normal invocation of regedit.

I would have spent a long time before I found that approach, if ever.

Joe M
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.