Exchange 2010 recreating ECP

Was getting access denied in owa options.  After doing some troubleshooting and nothing else working I decided to recreate ECP

I deleted ECP using powershell Remove-EcpVirtualDirectory -Identity "Server01\ecp (default Web site)"

Tried creating new with New-EcpVirtualDirectory -Identity "Server01\ecp (default Web site)"

But get the following error:

Cannot process argument transformation on parameter 'DomainController'. Cannot convert value "(Server.Domian)\ecp
 (default Web site)" to type "Microsoft.Exchange.Data.Fqdn". Error: ""(Server.domain)\ecp (default Web site)" isn
't a valid SMTP domain."
    + CategoryInfo          : InvalidData: (:) [New-EcpVirtualDirectory], ParameterBindin...mationException
    + FullyQualifiedErrorId : ParameterArgumentTransformationError,New-EcpVirtualDirectory
    + PSComputerName        : (Server.domain)

I read a article that where you can use metabase to remove leftover ecp file that you dont see in IIS manager, so I did that also....still same error..

Anyone have an idea what I can do?
LVL 1
homesgAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Any reason you didn't use the wizard in EMC to do the recreation?
Server Config, right click on the server and choose Reset Virtual Directory.

If you run new-ecpvirtualdirectory on its own - without any switches, what happens? If it prompts you for the steps, if you enter them at that point, does it work?

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
homesgAuthor Commented:
The wizard would hang up, but when I ran new-ecpvirtualdirectory without the switches it worked and corrected the issue I was having so thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.