Why won't my MS Exchange 2007 server pass secure POP3 incoming email?

My MS Exchange 2007 server does not pass secure POP3 incoming email.  We are using MS Outlook 2007 and/or 2010.  Incoming port is 995 with SSL encryption, outgoing port is 587 with encryption auto.

We can send email.  The issue is only receiving.

This work long time ago before we renewed our SSL certificate.

Any thoughts?
Luis MendozaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Luis MendozaAuthor Commented:
Does the ssl certificate "friendly name" (not the issued to) need to match POP3 x.509 certificate name? in order for the pop3 encryption to work?
Simon Butler (Sembee)ConsultantCommented:
The friendly name doesn't matter.
The common name does though - that does need to match.

Why are you using POP3 with Outlook rather than Outlook Anywhere? POP3 is a horrible protocol, too easy to lose email.

Luis MendozaAuthor Commented:
1.  How can I verify that the common name is matching on the server, and certificate?

2.  any other things I should check that are causing me this issue?

The use of POP3 is not my call.  However, I'm still required to support it.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Luis MendozaAuthor Commented:
I am getting this general error in Outlook:

Task 'username - Receiving' reported error (0x800CCC1A) : 'Your server does not support the connection encryption type you have specified. Try changing the encryption method. Contact your mail server administrator or Internet service provider (ISP) for additional assistance.'

We have the following services enabled in exchange server with ssl certificate:

I have also verified that POP3 is a Enabled feature for the affected user.
Simon Butler (Sembee)ConsultantCommented:
That sounds like you don't have SSL enabled on the POP3 protocol.
You need to look at the SSL certificate bound to POP3 and view the common name. Then check that is what is set on the POP3 server.

Luis MendozaAuthor Commented:
Where do you find this?  I do not see it when I view the certificate.
Simon Butler (Sembee)ConsultantCommented:
The common name IS the name you see on the certificate.

Luis MendozaAuthor Commented:
The issue was MS Update or patch KB3061518.  There is a possibility that code in the patch was not able to establish a proper communication at what I assume should have been with key length of 1,024 bits.  I plan to contact Microsoft to let them know and to see if they have a workaround other than just uninstalling the patch.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Luis MendozaAuthor Commented:
After further analysis, the issue happened after installing Microsoft Updates.  Our team analyzed the patches, and found a possible cause, tested, and addressed the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.