Receiving 1040 application log error.

I am getting a 1040 event log application error at various time intervals (usually every 15-20 minutes or so).
Not sure how to make sure the firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology (make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed)?  Thank you!

Log Name:      Application
Source:        MSExchange ActiveSync
Date:          5/19/2015 11:37:53 AM
Event ID:      1040
Task Category: Requests
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      BCSERVER.bc.local
Description:
The average of the most recent heartbeat intervals [470] for request [Sync] used by clients is less than or equal to [540].
Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed.
ImImInAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffery HayesSystem Support Technician Commented:
Looks like this is occurring because either the Firewall isn't configured to let HTTP(S) request live longer than the minimum heartbeat interval.

If ActiveSync is working and you don't want this application log to be generated do the following.

 
Open Registry on the Exchange server, and locate to the registry key:
 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
 
Please set the values (MinHeartbeatInterval and MaxHeartbeatInterval) to zero.
 
After you change both the values don't forget to Restart IIS admin service.

Here's some good info on how to set it up however so that the problem is fixed rather than just turning off the alert.

https://support.microsoft.com/en-us/kb/905013

As well as this https://technet.microsoft.com/en-us/library/cc725820(WS.10).aspx 

From this old question which was asked a while ago.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_28250179.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ImImInAuthor Commented:
I increased the "TCP Connection Inactivity Timeout"  on the HTTPS (WAN to LAN) firewall rule (Sonicwall-Windows firewall is disabled) and this did not improve the performance.

I will configure per your suggestion above (for ActiveSync is working) on the registry but if you have any other suggestions without having to do this i would be grateful.
0
ImImInAuthor Commented:
I don't see a 'MasSync' in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters" path?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Jeffery HayesSystem Support Technician Commented:
Did you read this link?

https://support.microsoft.com/en-us/kb/905013

The following table contains the values that can be modified as they relate to the heartbeat interval. These registry values are not present in a fresh installation of Exchange Server 2003 SP2. The server reverts to hard-coded defaults if these registry values are missing. The administrator must manually create these registry values if he or she wants to set the values. These values can be set in the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters


Looks like you might have to create the values as what version of Exchange are you running from my understanding are you on Small Business Server?

However this guy made the change and still had the issue.

http://www.jasonslater.com/2008/11/18/dealing-with-event-id-1040-ms-exchange-activesync/ 


Here's another Experts Exchange answer for this previously.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27922346.html
0
ImImInAuthor Commented:
Yes, I read the article, ran accross this before I ever submitted ticket to ME.
I am on Exchange 2010 (SBS 2011), do you know if this will work on Exchange 2010?
0
ImImInAuthor Commented:
OK...
I tried the following on my Exchange 2010:

Release version of Exchange 2007

    1) In Notepad, open the Sync web.config file on the Client Access Server. By default, that location is under \Program Files\Microsoft\Exchange Server\ClientAccess\Sync.
    2) Search for and modify the following values as needed:
    <add key="MinHeartbeatInterval" value="60"></add> <add key="MaxHeartbeatInterval" value="3540"></add>

In creased "MinHeartbeatInterval" to 1800 and decreased "MaxHeartbeatInterval" to 2700.

Do you have any comments on what I did?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.