Cisco 877 VA no ADSL connection.?

Hi,

Can someone please help me out here I can't seem to connect to my ADSL provider I get a solid carrier detect light but no PPP light.
Please can someone explain a fix for this in simple terms as I'm not fully conversant in cisco CLI but can do it if walked through it.
I've attached the config below:-

-------------------------------------------------
Current configuration : 5076 bytes
!
! No configuration change since last restart
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HBS
!
boot-start-marker
boot config flash:usbflash0
boot-end-marker
!
!
no logging console
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-3233774123
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3233774123
 revocation-check none
 rsakeypair TP-self-signed-3233774123
!
!
crypto pki certificate chain TP-self-signed-3233774123
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33323333 37373431 3233301E 170D3133 30393137 31333338
  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32333337
  37343132 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B254 C04208D2 ABF68D18 5B77C54E 7AE24FE2 6493A65E 3D67BDFA AC05CAAD
  2209BE2E DC621CE2 5682517E 3CA06F61 0C0FC713 2C0F84D8 FEBBF5CC 81A6EF17
  B768E110 C5FC6FB2 2750875C 7203BC16 39335314 CCF32034 5E042C2C 15F03FF1
  1BDF97A0 DBA757F9 42783E39 6AF59906 ACA416B4 3EC1E4D5 C935799B 9167D1FC
  AB850203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1403A635 385A6809 603E2C4A FF6F439B 6995E393 A2301D06
  03551D0E 04160414 03A63538 5A680960 3E2C4AFF 6F439B69 95E393A2 300D0609
  2A864886 F70D0101 05050003 81810073 3157A85E 120A5B1D 6C25453C 0DFB0F82
  9156EFF7 64E1A26B 4675C488 EF291E25 6C6C25CB 8CA95AB1 1FF6C2EB C12636D7
  50E2B83C A87225B3 87AC7CE1 679B1801 49E4B859 4BED67E2 6783EFB6 A50CC616
  C32228AD 625331FD 85361CEC 11E196E9 26D9638E 98D3235A 9D425AE8 1F06FEE0
  D332ED58 E0504C61 03F8939E 1EEF55
        quit
ip source-route
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.2.1 192.168.2.99
!
ip dhcp pool VLAN10
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 domain-name hb-s.dyndns.org
 dns-server 208.67.220.220
 lease 4
!
ip dhcp pool VLAN20
 import all
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
 domain-name hb-s.dyndns.org
 lease 4
!
!
ip cef
ip domain lookup source-interface Vlan10
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip inspect name MYFW tcp
ip inspect name MYFW udp
ip ddns update method dyndns
 HTTP
  add http://*********:*********@members.dyndns.org/nic/updatesystem=dyndns&hostname=<h>&myip=<a>
 interval maximum 0 0 5 0
!
ip ddns update method no-ip
 HTTP
 interval maximum 0 0 3 0
!
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO887VA-SEC-K9 sn FCZ1605C2P9
!
!
username sysop privilege 15 password 7 08254E455D4C5D14
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
 switchport access vlan 20
 no ip address
 spanning-tree portfast
!
interface FastEthernet1
 switchport access vlan 10
 no ip address
 spanning-tree portfast
!
interface FastEthernet2
 switchport access vlan 10
 no ip address
 spanning-tree portfast
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan10
 description Internal Network
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan20
 description Guest Network
 ip address 192.168.2.1 255.255.255.0
!
interface Dialer0
 ip ddns update hostname hbs.dyndns.org
 ip ddns update dyndns
 ip ddns update no-ip
 ip address negotiated
 ip access-group Internet-inbound-ACL in
 ip nat outside
 ip inspect MYFW out
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname *********@ic-adsl.co.uk
 ppp chap password 0 *********
 ppp ipcp dns request
 ppp ipcp address accept
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.40 80 interface Dialer0 80
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip access-list extended Guest-ACL
 deny   ip any 192.168.1.0 0.0.0.255
 permit ip any any
ip access-list extended Internet-inbound-ACL
 permit udp any eq domain any
 permit udp any eq bootps any eq bootpc
 permit icmp any any echo
 permit icmp any any echo-reply
 permit icmp any any traceroute
 permit gre any any
 permit esp any any
 permit tcp any any
 permit tcp any any eq www
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
 password 7 09484C024D504F11
line aux 0
line vty 0 4
 password 7 070B23471A5C4106
 login
 transport input all
!
end
------------------------------------------------

Hope this helps I' ve omitted any usernames & passwords with an asterix.

Thanks
Craig
Craig WalkerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TrustGroup-UAECommented:
Hi,

I'm not near any Kit to test at the moment but I have noticed one thing that jumps out:-

interface ATM0
  no ip address
  shutdown

Your Interface ATM0 is in a Shutdown State.

Lest bring this up before doing anything else. From the Router Prompt type:-

en
conf t
int ATM0
no shut
exit
exit
copy run start

Regards
TME
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Craig WalkerAuthor Commented:
Hi thanks for that it's now working fine m8

Thanks again for you help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.