vsftp -- 553 could not create file

On one of several CentOS servers, I cannot push files.  From my /etc/vsftpd/vsftpd.conf
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES

Open in new window


The folder into which I was attempting to push the files belonged to the user under whose credentials i was logged in.
chown -R myFtpUser .
chmod -R 755 .

still, 553 could not create file

So I changed the folder ownership to the ftp user -- presumably the user under whose credentials the vsftpd daemon runs.

Same result.

What else do I need to check?

Thanks!
LVL 32
Daniel WilsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

omarfaridCommented:
Are you facing this problem with this user only or all other users?

Are you sure that when you login to ftp that you are in that directory?

Did you restart vsftpd after doing changes in /etc/vsftpd/vsftpd.conf ?
omarfaridCommented:
The issue could be also related to selinux. Try to disable it, reboot the system, then try to ftp. If the problem is solved, then you need to enable selinux and let selinux allow ftp.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Daniel WilsonAuthor Commented:
Yes, I restarted after my conf file changes.  that's the only user I've tried.

selinux ... checking how to disable that ...
Daniel WilsonAuthor Commented:
Disabling selinux did the job.  That is good enough for tonight. :)

Later I'll reconfigure selinux.

Thanks for the help!
omarfaridCommented:
Welcome
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.