Name is not removed from the outlook global address book and OWA after deleting account from AD

Hi

I deleted user on the AD and the mailbox was disconnected. I then permanently deleted the disconnected mailbox.
from the following command

Remove-Mailbox -Database <Database-Name> -StoreMailboxIdentity <MailboxGuid> -confirm:$true.

After running this command the mailbox that was in the disconnected mailbox(Exchange Management console) is now removed. I ran this command yesterday and was thinking the name in the global address book must have been removed by this time. But when I did a search for the user name PTH the name still exists on the address book both on OWA and outlook client. Is there any way of removing this name PTH

I ran the following command and still the name PTH is listed on the address book.
[PS] C:\Windows\system32>get-offlineaddressbook | update-offlineaddressbook
[PS] C:\Windows\system32>

Any help to sort to much appreciated. Please post me some tutorials
Thanks
lianne143Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

A KarelinCommented:
The global address book update once a day. Outlook update cash once a day. So your can see result after 48 hours max.
Try turn off Cached Exchange Mode in Outlook and check global address book.
Tony GiangrecoCommented:
If you don't see the change, you can go into the Exchange console and regerate the global address book.
lianne143Author Commented:
Is there any particular command to re generate the global address book.
How long will this take and will the address book become offline during the re generation ?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Will SzymkowskiSenior Solution ArchitectCommented:
I think your teminology for this is incorrect. It is not the GAL (global address list) you are talking about it is the OAB (offline address book). A good way to test this is to login to OWA and check the GAL and see if the user exsits. If it doesn't then there might be an issue with your OAB.

At this point if replicaiton has already passed and it is still not removed then you might need to re-create the OAB
Recreate Offline Address Book

Will.
lianne143Author Commented:
It is 41 hrs  since I deleted the account from the AD. I logged into the OWA  and did a search for the name and the user still exists on the GAL.
Will SzymkowskiSenior Solution ArchitectCommented:
It is possible that you might have Active Directory Replicaiton issues. Have you check your AD replicaiton making sure that it is working accordingly?

- repadmin /replsum
- repadmin /showrepl
- repadmin /bridgeheads
- dcdiag /v

Will.
lianne143Author Commented:
Thanks Will

I will run these commands on the Domain controller and get back to you.
lianne143Author Commented:
Hi

Please find the attached  and I ran  these commands and please let me know if there is any replication errors
repadmin /replsum
repadmin /showrepl
AD-replication.txt
A KarelinCommented:
ADC-002               44m:04s    4 /  10   40  (8524) The DSA operation is
unable to proceed because of a DNS lookup failure.
lianne143Author Commented:
Please post me some tutorials to resolve this issues, not sure as how to resolve this. Please let me know if you want the results for dcdiag /v and I will post.


Thanks
A KarelinCommented:
Try running dcdiag /test:dns to make sure your records are OK.  If it returns errors add the verbose (/v) switch for details
lianne143Author Commented:
Please se the attached results for dcdiag /test:dns
dcdiag-test-dns-.txt
A KarelinCommented:
Did you run dcdiag /test:dns on ADC-002?
lianne143Author Commented:
Attached the results for dcdiag /test:dns on ADC-002
DCDiag-test-dns-adc-002.txt
A KarelinCommented:
TEST: Basic (Basc)
                  Warning: adapter [00000010] vmxnet3 Ethernet Adapter has
                  invalid DNS server: 10.14.106.241 (<name unavailable>)

Open in new window


DNS server: 10.14.106.241 (<name unavailable>)
               1 test failure on this DNS server
               PTR record query for the 1.0.0.127.in-addr.arpa. failed on the DN
S server 10.14.106.241               Name resolution is not functional. _ldap._t
cp.domain.local. failed on the DNS server 10.14.106.241

Open in new window


You need to fix that.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.