An attempt to resolve the DNS name of a domain controller in the domain being joined has failed.

Hello Experts
I have to move the server to a new location and reconnected all the workstatations back however now when I try to connect to the domain I get this error. When I run a nslookup,  I get this

DNS request timed out.
    timeout was 2 second
Default Server:  UnKnown
Address:  192.168.5.12

Please can someone advice?

Thanks
merajohnAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

matrix8086Commented:
can you ping the IP of the DNS? I would bet that it's a connection problem or a routing problem
Tony GiangrecoCommented:
Check and make sure all your workstations and server still use the same IP scheme as they had in the old location.

If they were using 192.168.1,,, verify this still exists.   Also make sure the server uses the same IP scheme.

Verify your network connections, router, switches and run a ping test from pc to Pc, pc to Server and server to Pc's.

If anything fails, you need to resolve those issues first.
Christopher KibbleCommented:
The first things I'd check:  Is 192.168.5.12 the right internal IP address for your DNS?  Is DNS running on your DC, or somewhere else?  Can you ping the DNS Server / Domain Controller?  Is the DNS Service running?
Defend Against the Q2 Top Security Threats

Were you aware that overall malware worldwide was down a surprising 42% from Q1'18? Every quarter, the WatchGuard Threat Lab releases an Internet Security Report that analyzes the top threat trends impacting companies worldwide. Learn more by viewing our on-demand webinar today!

merajohnAuthor Commented:
Hello All
Thank you so much for looking into this for me, I am able to ping to the server - no problem.
I have not changed anything really except that most of these workstations went on to the internet before the server was up, they have to chose "Work Network" first time they connected to the internet.
I have connected the server back on the network the next day and everything went on as normal but looks like all the workstations are unable to connect to the domain.
Please advice
ipconfig.png
merajohnAuthor Commented:
Yes, I am sure 192.168.5.12  is our DNS server
matrix8086Commented:
check if the DNS service is up and running on the DNS server, Check the firewalls if the traffic on port 53 UDP is allowed

restart the workstations and it should work

To be sure that everything is working normal: FSMO role server must be turned on first, then the rest of AD integrated servers, then the workstations

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
merajohnAuthor Commented:
Hi matrix8086

I have started the work stations quite a few times, shall I also reboot the serveR?

>> To be sure that everything is working normal: FSMO role server must be turned on first, then the rest of AD integrated servers, then the workstations

Please can you advice how can I go about doing this?

I am sorry I have very very limited knowledge of the network.  ):

Internet drops every 2 minutes as well from most of the workstations
matrix8086Commented:
"Internet drops every 2 minutes as well from most of the workstations" - what does it means? You have Internet connection problems? If the answer is yes, let's resolve that in the first place! It can be the resolution for all problems!
merajohnAuthor Commented:
Hi
Yes, this is another issue started today, I thought it was somehow related to the DNS ? its just dropping every 2 minutes and coming back within 2 seconds..
network-issu.png
matrix8086Commented:
The network name is not necessary to be shown. but you have a network connection issue which should be fixed!

Check your switches, check for loops connections (2 switches connected with 2 ethernet cables, not only one, and check if 2 ports from the same switch to not be connected by mistake)

Eventually restart  the switches, or shut them down all of them and start one by one to identify which one has issues
Berlin142Commented:
What does it mean that you have moved the server to a new location? How These locations are connected? If you for example try to root your address space, this will not work correct. Please verify your routing tables first, if you use natting, then also check this. And look for the address space. If you have for example a subnet mask by 255.255.255.0 and a network address of 192.168.1.x/24 on both sides, then this will never work. You need a unique path to your server, where the IP packets can be routed.
merajohnAuthor Commented:
Hi Matrix
Yes, I have reverted back the changes I tried to do last night. ie: connect 2 switches to 2 separates WAN ports on the Netgear firewall and I think that was making the connection to drop. Looks like internet connect is on now. Thanks

I can now focus on the DNS issue now
matrix8086Commented:
OK!

First: check if the DNS service is on and accesible. If the answer is yes, try to ping DNS server from a workstation and if it's OK, restart the workstation and see what's happening
merajohnAuthor Commented:
Hi,
>> check if the DNS service is on and accesible
where can I check if its on?

>> ping DNS server from a workstation
I get 4 replies from 192.168.5.12 when I ping it

>> After restarting the workstation, its still the same.

I can see the PC is connected to the domain but when I try to join again its giving me the original error...
domain.png
matrix8086Commented:
If is already connected to the domain, you have to disconnect first, in order to reconnect again. I don't think you have a DNS or a connection to AD issue.

Let's start again: what is wrong in your network, describe the bad behavior, but with precise terms.

"I can't connect to the domain" is not a good description and I think it is a bad conclusion from you!
merajohnAuthor Commented:
Hi, I have removed this PC from the domain and now unable to join. Please see the attached screenshot
error.png
matrix8086Commented:
Can you ping the DC by IP, name and FDQN?
Can you ping the DNS server by Name and FdQN?
is the right DNS IP in the network setting of the pictured workstation?
merajohnAuthor Commented:
Hi,
I can ping by IP and by name, but not with FDQN

DNS server name on the server is: GR-SERVER-02 and IP also seems right ie: 192.168.5.12
ping.png
matrix8086Commented:
What's the IP of the DC? What's the IP of the pictured workstation? Check on the DC and DNS servers if all automatic starting services are running (type in Start->Run services.msc)
merajohnAuthor Commented:
Can the DC and DNS server has a same IP?  I use RDP to connect to server using 192.168.5.12 and I am getting same IP for the DNS server.

IP on the workstation is 192.168.5.141
matrix8086Commented:
Yes, it can be, but you have to know exactly each role on which server is.

From the DNS server do this:

Start -> Run -> cmd -> nslookup    
set type=all
_ldap._tcp.dc._msdcs.Your-domain-name

Your domain name I think is Giftrepublic
merajohnAuthor Commented:
I have tried , had no response from the server message

>>
_ldap._tcp.dc._msdcs.GiftRepublic

Open in new window

domain-name
dns-server.png
matrix8086Commented:
From your response it can see that is no DC for that domain. Or the name of the domain is wrong, or the DC is turned off. It sould be a grserver01 as along as the DNS is 02 ...

Chec the services in DNS server to see if AD is registered, automaticaly starting, running or not. Nobody knows how many servers are in that domain?
merajohnAuthor Commented:
ah that might be the case, I can see there is another 2003 server which is not connected yet but I know it was named GR-Server-01

let me hook this server up to the network, thank you
merajohnAuthor Commented:
Hi Matrix
I have connected grserver01 to the network, I can  ping it from server 02

When I try to ping www.google.co.uk on command prompt of server01,  I got "Ping request could not find host google.co.uk" error, however I can ping it by an IP address

AD is registered on the server 02, all automatic services are running on both the servers...

I am still getting "unknown can 't find the _ldap... : No message from the server"  error message

Please advice
newbie27Commented:
Hi
If you have not made any major changes to DNS Server ie: changing IP addresses etc then usually restarting the DNS services on the Domain Controller and doing ipconfig /flushdns on the workstations usually resolves the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.