how to get 2811 router out to internet talk to switch

i am trying to setup my cisco 2811 router what are the steps to get it out to internet and connect to switch  so i can plug in my laptop via dhcp from the cisco router  and the laptop is assigned a private ip address.
charles11212Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patrick BogersDatacenter platform engineer LindowsCommented:
Hi,

It depends several questions.
Is your MODEM/ROUTER a DHCP server?
Depending first answer, what fysical ports are you planning to use? 1 for WAN and 1 for LAN (switch)
Next, are you able to login the router using a blue console cable?
charles11212Author Commented:
yes i have a home lab with static ip from cablevision. i am using  my ethernet cable connected to my cable modem to connect to my cisco 2811 router to fa0/0  and fa0/1 connect to my 3750 cisco switch. i want to manually setup the router configs  on the cisco router  i have all of the static ip info dns server,  i need to know how to nat out of the fa0/0 and what goes inside . a step by step process would help. also to test i want to plug my laptop in my  3750 switch to see if i can browse the internet from the router configuration.
Patrick BogersDatacenter platform engineer LindowsCommented:
Login to the router and type

config t

interface FastEthernet0/0

ip address dhcp

*this command accepts a DHCP address given by the cablevision router*

for your other interface (FastEthernet0/1):

config t

interface FastEthernet0/1

ip address 10.1.1.1 255.255.255.0
(this is an example which offers 255 ip adressess on the 10.1.1.x network, change the ip addess range that you want for your PCs, printer, etc at home.)

If you want to use DHCP addressing done by cisco router for your devices at home, then you would need to define an IP DHCP pool and specify

ip dhcp pool LAN
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
dns-server
 (DNS servers supplied by the ISP)


You will also need a default route (called last resort) toward your cablevision modem

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
See more at: https://supportforums.cisco.com/discussion/10799196/basic-cisco-2811-configuration#sthash.waMsQfgq.dpuf
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

charles11212Author Commented:
question my cable modem i have static ip address a block of 5 . /29 can i use my static ip for fa0/0 and create inside ip addresses for fa0/1 and still create dhcp pool and access-list and nat inside ip address to fa0/1 ?. if so please show me a step by step on how to with static ip's thanks for the help.
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi again,

Off course you can but it depend. Does your cablevision modem/router is setup as DHCP or as a bridge?

What happens is you connect your laptop directly to it? Does it give you a public ip in the range of 5 (then it is a bridge) or does it give you a dynamic ip (in that case it is using DHCP)

Lets pretend fa0/0 and fa0/1 are living on 2 planets but in the same galaxy. You can do whatever you like on both off them and they will not know about each others config. So fa0/0 can be static and fa0/1 can be dynamic, ACL-d, Natted, whatever.
Benjamin Van DitmarsSr Network EngineerCommented:
Youre configuration is going to look like this

ip domain name {your local domain}
ip auth-proxy max-login-attempts 5
ip auth-proxy max-nodata-conns 3
ip admission max-login-attempts 5
ip admission max-nodata-conns 3

ip dhcp pool LAN
  network 192.168.0.0 255.255.255.0
  default-router 192.168.0.254
  dns-server 8.8.8.8 8.8.4.4
!
ip dhcp excluded-address 192.168.0.254
{add this rule for every ip that you wanna exclude}


interface FastEthernet0/0
 description Link WAN
 ip address {wan IP} 255.255.255.248
 load-interval 30
 duplex full
 speed 100
 ip nat outside
 no shutdown
!

interface FastEthernet0/1
 description LAN
 ip addres 192.168.0.254 255.255.255.0
 ip verify unicast reverse-path
 ip nat inside
 ip virtual-reassembly
 no mop enabled
 no shutdown
!

ip route 0.0.0.0 0.0.0.0 {gw provider}
ip nat inside source list AllowNatList interface fastethernet 0/0 overload

ip access-list extended AllowNatList
 permit ip 192.168.0.0.0 0.0.0.255 any
!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.