Can't write to Android Internal Memory

Hi, guys.  I'm having a hell of a time writing to my internal memory.  I have a developer edition Moto X that is rooted and I have several tools to connect and write to it.

OK, this is what I've tried.  

-- I remounted the "system" partition and it shows up as "rw" when I run mount!  Yet I still can't write to it via SFTP.  I get a "read-only" memory error.
-- I can write to the SDcard and I tried writing my file there and then moving it to internal memory using ES file explorer.  Again I got the "read-only" memory error.  

Is this a corrupt file system, or is this normal?  Is this a user/shell permission issue?  Please help....I'm no Linux expert and I really need to put a script in internal memory.  Thanks in advance to all.
LVL 1
Thomas StrussAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
You need to set ES explorer to use root.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas StrussAuthor Commented:
Oh...my...god.  That did it.  Thanks, gheist.  BTW, for those who want to mess with files on the internal drive you need two things:
1) a rooted bootloader busy-box and super-user installed.
2) ES explorer WITH the "root explorer" turned on.  This is found by going to menu button -> tools -> scroll down to "root explorer".  

I was able to copy my script with no problem from the sdcard to /etc after this button was pressed.
Thomas StrussAuthor Commented:
Oh, and I just  wanted to add that remounting in rw mode was not needed.  I remounted in ro mode again and it still works.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.