issues with GNS3 or top;ology?

I am having weird issues with GNS3 topology or maybe config issue. The below image shows my topology.
topology.jpgWhenever I turn all the devices ON, I can ping 15.15.15.15 from any host for ex from host 10.153.1.19 far left. At first, traceroute indicates that the route goes to  10.153.1.1 which is right and then to 10.10.10.10 but as you can see, after few traceroutes, it goes to 10.153.1.1. then 10.153.0.3 (0.3 is the SW2 VLAN svi 5.) Why it is hitting that switch at all? It's an HSRP switch. I have SVI configured for each vlan on the 2ND switch. I have vlans configured with virtual IP machine both sides. I have no idea why it hits the 2nd switch. If I drop the 2nd switch, I can no longer ping 15.15.15.15 which is wrong since it shouldn't need the 2nd switch at all to get to 15.15.15.15.

The second issue I had before I found the above more concerning  was that when both switches SW1 and SW2 are on, I can obviously ping across all VLANS but when I shut off SW1, I can STILL ping all vlans except, when I do "clear arp-cash" on the host, I can no longer ping any vlan.

I am guessing this all makes no sense and it might very well be a gns issue. This will be topology I will be implementing into a real network scenario.


HOST (PC1)
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 24 msec 8 msec 12 msec
  2 10.10.10.10 40 msec 108 msec 24 msec
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 12 msec 20 msec 4 msec
  2 10.10.10.10 16 msec 20 msec 16 msec
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 44 msec 12 msec 52 msec
  2 10.153.0.3 44 msec
    10.10.10.10 68 msec
    10.153.0.3 56 msec
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 12 msec 8 msec 28 msec
  2 10.153.0.3 24 msec 40 msec 68 msec
  3 10.153.0.3 !H
    10.10.10.10 24 msec 60 msec
PC1#cle
PC1#clear ar
PC1#clear arp-cache
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 1040 msec 8 msec 20 msec
  2 10.153.0.3 24 msec 40 msec
    10.10.10.10 24 msec
PC1#traceroute 15.15.15.15

Type escape sequence to abort.
Tracing the route to 15.15.15.15

  1 10.153.1.1 28 msec 12 msec 8 msec
  2 10.153.0.3 40 msec
    10.10.10.10 24 msec
    10.153.0.3 32 msec

Open in new window


SWITCH 1
links f1/8 between the two core's are my hsrp links
CORE#show standby br
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl1         15  150  P Active   local           192.168.100.15  192.168.100.5
Vl5         15  150  P Active   local           10.153.0.3      10.153.0.5
Vl6         15  150  P Active   local           10.153.6.3      10.153.6.5
Vl8         15  150  P Active   local           10.153.1.3      10.153.1.5
Vl9         15  150  P Active   local           10.153.2.3      10.153.2.5
Vl10        15  150  P Active   local           10.153.3.3      10.153.3.5
Vl12        15  150  P Active   local           10.153.12.3     10.153.12.5

Open in new window

CORE#show ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.100.1   YES NVRAM  up                    up
Vlan5                      10.153.0.1      YES NVRAM  up                    up
Vlan6                      10.153.6.1      YES NVRAM  up                    up
Vlan8                      10.153.1.1      YES NVRAM  up                    up
Vlan9                      10.153.2.1      YES NVRAM  up                    up
Vlan10                     10.153.3.1      YES NVRAM  up                    up
Vlan12                     10.153.12.1     YES NVRAM  up                    up

Open in new window

CORE#show run | i route
ip route 15.15.15.0 255.255.255.0 10.153.0.2

Open in new window


SWITCH 2

GIG_SW#show standby br
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Vl1         15  100    Standby  192.168.100.1   local           192.168.100.5
Vl5         15  100    Standby  10.153.0.1      local           10.153.0.5
Vl6         15  100    Standby  10.153.6.1      local           10.153.6.5
Vl8         15  100    Standby  10.153.1.1      local           10.153.1.5
Vl9         15  100    Standby  10.153.2.1      local           10.153.2.5
Vl10        15  100    Standby  10.153.3.1      local           10.153.3.5
Vl12        15  100    Standby  10.153.12.1     local           10.153.12.5

Open in new window

GIG_SW#show ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.100.15  YES NVRAM  up                    up
Vlan5                      10.153.0.3      YES NVRAM  up                    up
Vlan6                      10.153.6.3      YES NVRAM  up                    up
Vlan8                      10.153.1.3      YES NVRAM  up                    up
Vlan9                      10.153.2.3      YES NVRAM  up                    up
Vlan10                     10.153.3.3      YES NVRAM  up                    up
Vlan12                     10.153.12.3     YES NVRAM  up                    up

Open in new window

GIG_SW#show run | i route
ip route 15.15.15.0 255.255.255.0 10.153.6.2

Open in new window

topology.jpg
LVL 3
Shark AttackNetwork adminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shark AttackNetwork adminAuthor Commented:
also,

SWITCH 1
interface Vlan1
 ip address 192.168.100.1 255.255.255.0
 standby 15 ip 192.168.100.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan5
 ip address 10.153.0.1 255.255.255.0
 standby 15 ip 10.153.0.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan6
 ip address 10.153.6.1 255.255.255.0
 standby 15 ip 10.153.6.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan8
 ip address 10.153.1.1 255.255.255.0
 standby 15 ip 10.153.1.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan9
 ip address 10.153.2.1 255.255.255.0
 standby 15 ip 10.153.2.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan10
 ip address 10.153.3.1 255.255.255.0
 standby 15 ip 10.153.3.5
 standby 15 priority 150
 standby 15 preempt
!
interface Vlan12
 ip address 10.153.12.1 255.255.255.0
 standby 15 ip 10.153.12.5
 standby 15 priority 150
 standby 15 preempt

Open in new window


SWITCH 2
interface Vlan1
 ip address 192.168.100.15 255.255.255.0
 standby 15 ip 192.168.100.5
!
interface Vlan5
 ip address 10.153.0.3 255.255.255.0
 standby 15 ip 10.153.0.5
!
interface Vlan6
 ip address 10.153.6.3 255.255.255.0
 standby 15 ip 10.153.6.5
!
interface Vlan8
 ip address 10.153.1.3 255.255.255.0
 standby 15 ip 10.153.1.5
!
interface Vlan9
 ip address 10.153.2.3 255.255.255.0
 standby 15 ip 10.153.2.5
!
interface Vlan10
 ip address 10.153.3.3 255.255.255.0
 standby 15 ip 10.153.3.5
!
interface Vlan12
 ip address 10.153.12.3 255.255.255.0
 standby 15 ip 10.153.12.5
!
ip classless
ip route 15.15.15.15 255.255.255.0 10.153.6.2

Open in new window


ASA
sla monitor 10
 type echo protocol ipIcmpEcho 10.153.0.1 interface OUTSIDE
 num-packets 3
 timeout 1000
 frequency 3

track 1 rtr 10 reachability


PrimaryASA#  show run | i route
route INSIDE 0.0.0.0 0.0.0.0 10.153.0.1 1 track 1
route INSIDEBACKUP 0.0.0.0 0.0.0.0 10.153.6.3 10
route OUTSIDE 15.15.15.0 255.255.255.0 10.10.10.10 1

Open in new window

JustInCaseCommented:
1. Default gateway on hosts is wrong. You should never in traceroute get response from 10.153.1.3  or 10.153.1.1 .... you should always get response from 10.153.1.5 - virtual address should be your gateway.

2. You should also track status of reachability on your interfaces to ASA - to check is internet available. Otherwise - what will cause HSRP to Convert to other switch to be active if path to internet becomes unavailable?
Shark AttackNetwork adminAuthor Commented:
1. if I set my default- gateway on hosts to the virtual IP, will the host sometimes choose to go to SW2 rather then SW1? I would only want host going to 15.15.15.15 via SW1 unless SW1 is down. There will be no traffic balancing or anything of that sort right?

2. I initially thought that HSRP does this alone. So basically I need to configure IP SLA with tracking on the switches interfaces that go to each ASA? I thought that since HSRP is active, once SW1 fails, Virtual IP will kick in somehow and forward traffic via SW2 out.

thanks
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

JustInCaseCommented:
1. Whole point of using HSRP is usage of virtual IP address. But for your question, always is used the same switch (switch that is active) usually higher priority (if preempt is configured). If priority is higher and preempt is not set, first switch that boots will be active.
If SW1 loses connection with SW2 than SW2 becomes active.

2. HSRP never do anything alone, does what you tell him to do.
You need to track interfaces (or use IP SLA - better way, since sometimes link is up, but there's no traffic)
standby track gi0 20 (this will decrease priority 20 if Gi0 is down)
and if state of interface is changed (or IP LSA have false as result) you need to decrease priority on active switch. Also you want to configure both switches to preempt, reason is if preempt is not set even if HSRP priority of one switch then other and preempt is not set, nothing happens, no change in active - standby.... the only change will be if SW1 loses connection with SW2.

Kick somehow is KEY - you make it happen :)
Also you don't want switch preempt as soon as it is back online. Give some delay to preempt, 60 seconds at least. If device is faulty could restarting continuously.  
standby 1 preempt delay minimum 60

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shark AttackNetwork adminAuthor Commented:
thanks for clearing things up for me. When I changed the hosts gateways to Virtual IP, I still get the SW1's vlans in traceroute though. Not sure why, and still the annoying 10.153.0.3 especially

PC6#traceroute 209.117.163.165

Type escape sequence to abort.
Tracing the route to 209.117.163.165

  1 10.153.2.1 28 msec 68 msec 32 msec
  2 209.242.21.169 36 msec
    10.153.0.3 20 msec 92 msec
PC6#traceroute 209.117.163.165

Type escape sequence to abort.
Tracing the route to 209.117.163.165

  1 10.153.2.1 8 msec 8 msec 16 msec
  2 209.242.21.169 52 msec
    10.153.0.3 28 msec 24 msec

Open in new window


This might be the ASA right? IP SLA not configured correctly?
Shark AttackNetwork adminAuthor Commented:
there was also a GNS issue as well
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.