When accessing OWA offsite or internally I get this error: Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to

This started about a week ago, I get this error when accessing remote.<domain>.com/owa
"Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to remote.<domain>.com/owa"
It gives me this error in IE, firefox and chrome... could this be an SSL issue with a certificate?
advantagecAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompProbSolvCommented:
Have you enabled those in the browser?

For example, in IE do:
Tools
Internet Options
Advanced
Scroll down to Security
below that you should see the checkboxes for the TLS versions
0
advantagecAuthor Commented:
Yes all are enabled...
0
CompProbSolvCommented:
Not sure what is going on then.  If there were a problem with the certificate I'd expect a different error.

Does this happen on all computers trying to access OWA?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

advantagecAuthor Commented:
No, some places I have tried get this in firefox:
The connection to the server was reset while the page was loading.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer's network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

which makes me think it might be an issue with IIS
0
CompProbSolvCommented:
IIS issues are certainly a possibility.

Do you have the same problems when trying to access OWA with IE on the IIS server?
0
advantagecAuthor Commented:
Same error when accessing "localhost/owa" on mail server in IE
0
advantagecAuthor Commented:
Found the fix myself, Went to exchange certificates, right click, assign services to: IIS.... some how the service had gotten unassigned
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.