xampp tomcat

When I look at the xampp control panel I see the following error:
---------------

20:12:53  [Tomcat]       Problem detected!
20:12:53  [Tomcat]       Port 8080 in use by ""C:\Program Files (x86)\PostgreSQL\EnterpriseDB-ApachePHP\apache\bin\httpd.exe" -k runservice"!
20:12:53  [Tomcat]       Tomcat WILL NOT start without the configured ports free!
20:12:53  [Tomcat]       You need to uninstall/disable/reconfigure the blocking application
20:12:53  [Tomcat]       or reconfigure Tomcat and the Control Panel to listen on a different port
--------------

 I have already configured Tomcat to run on different ports - see attached server.xml file
So why the error message
Can someone please explain what is going on here
Thhis is running on Windows
server.xml
doctorbillTechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

A. Cristian CsikiSenior System AdministratorCommented:
You might want to change the apache port from httpd.conf

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
doctorbillTechAuthor Commented:
Thanks for that - I just realised that I was looking at the incorrect conf file
I tried to change the listening port to 890 (which is unused at present) and restarted the postgre service but I now get a page not displayed for the following:

http://localhost:890/phpPgAdmin/
http://localhost:890/

Postgre conf file which was changed:
C:\Program Files (x86)\PostgreSQL\EnterpriseDB-ApachePHP\apache\conf\httpd.conf

I changed the reference in the following places:
Listen 890
ServerName localhost:890
doctorbillTechAuthor Commented:
I am now really confused:

I open the following file:
C:\Program Files (x86)\PostgreSQL\EnterpriseDB-ApachePHP\apache\conf\httpd.conf

If I change the  following ports or even disable them:
Listen 8080
ServerName localhost:8080

The following still works even after doing the above and restarting the postgre services (and emptying web caches):
http://localhost:8080/phpPgAdmin/

Where is the postgre server getting it's port info from ??????
doctorbillTechAuthor Commented:
partially solved
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.