Cannot connect to PCs thru Anywhere Access

I have a SBS 2012 Essentials server.  I have setup Anywhere Access. User can login remotely at remote.companyname.com and open the shared files and see their assigned PC.  When they click on it it opens an RDP window but they get the error:

"Remote Desktop can't find the computer "pc1". This might mean that "pc1" does not belong to the specified network. Verify the computer name and domain that are trying to connect to.,

If I logon as the administrator, I can connect to the server in this manner.

If I am on-site connect to the wireless network the laptop can connect to the PCs in this manner after several tries.

Any ideas how to correct?

How can I force a certificate (self signed) as I think this might be the issue.
AlisanneLead CondultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlisanneLead CondultantAuthor Commented:
I have re-run the wizard and used the vanity address firmname.remotewebaccess.com. I get the same error if logged in as a user.

But if logged in as admin I can remote into the server thru RDP link. I still can not get to PC's as either admin or users.

Will a godaddy certificate help?
0
AlisanneLead CondultantAuthor Commented:
I have resolved the issue.  After testing on a third system (Surface pro 2), as it was not working on 2 brand new Surface pro 3 systems, I had success, using Chrome.

This lead me to believe that the server was setup correctly and that it was not a firewall/DNS/other issue.

On new Surface Pro 3 systems:

I turned off UAC
I added the site to compatibility mode
I added the site to trusted sites

it now works on 1 of the 2 systems. I am currently running updates and crossing my fingers for the 2nd system.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlisanneLead CondultantAuthor Commented:
It seams that IE is hit-and-miss at best. But seams to be working correctly in Chrome for now.

If anyone has a solid solution for fixing the connectivity in IE11 I would appreciate the advice.

Thank you,
Sanne
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Lionel MMSmall Business IT ConsultantCommented:
I don't have the answer but well done on your self resolution skills.
0
Spike99On-Site IT TechnicianCommented:
Indeed: kudos on your troubleshooting so far.

Since IE 11 seems to be the culprit, have you tried adding that URL to the Trusted Sites List?
0
AlisanneLead CondultantAuthor Commented:
I had resolved the issues prior to expert response.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.