Sharepoint 2010 - path too long? Only for some users

We have a Windows 2012 server running SharePoint Foundation 2010 (which will eventually be migrated to SharePoint 2013 Enterprise).

In the meantime we seem to be experiencing some odd issues, which initially looked to be related to path or URL length, but now I am unsure.

For example, there is a site:-

http://companyweb/Finance/restauranthome/Income%20Data%20Sheet/Forms/AllItems.aspx

When the person who "owns" this site attempts to upload a file called "Daily Income and Banking Sheet Master.xls" he gets the following error:-

The URL 'Income Daily Sheets/Daily Income and Banking Sheet Master.xls' is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is in the current Web.

This user has Full Control and Read permissions on the site. I log on using the administrator account (with no site specified permissions) and can upload a file with exactly the same name to the same site without any issue.

This has happened (so far) with two specific users on two different sites within SharePoint 2010.
LVL 17
Chris MillardAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Britt ThompsonSr. Systems EngineerCommented:
This occurs when the local path from the user's folder to the file is too many characters or contains an unsupported character. If someone else is able to upload the file I would start with the depth of the local path to the file since some users names are shorter than others they would be able to upload whereas a person with a longer name cannot. This is common when uploading from a file share or redirected folders.
0
Chris MillardAuthor Commented:
OK, that doesn't appear to be the issue. If I copy that file to my own desktop, or to the root of my drive, I cannot upload it - I get the same error. If I create a new text file with exactly the same name (including renaming it to a .xls) then it uploads just fine.
0
Britt ThompsonSr. Systems EngineerCommented:
If thats the case then you may be hitting some sort of limit in your document library. There's quotas and thresholds set for libraries out of the box. Say you have 5000 items in that list and the current query is hitting that limit you would see thing stop working properly. If you can upload the same file to a different document library that could be the problem.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Chris MillardAuthor Commented:
The document library is currently empty, and the document is only 1.4MB in size.
0
Britt ThompsonSr. Systems EngineerCommented:
what happens if you create a brand new blank Excel file with the same name? Curious if something else with the file is causing the issue. Macro enabled or encrypted workbook?
0
Chris MillardAuthor Commented:
I was wondering if it was a macro issue or not, so I removed all macros and tried again with the same result.

HOWEVER, delving through the SharePoint logs, I've just seen that the WSS_Content DB is full! Checking this in SQL Management Studio confirms 0.08MB left out of this 10GB DB
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Britt ThompsonSr. Systems EngineerCommented:
That would be one of those limits that'll get you!
0
Chris MillardAuthor Commented:
I eventually discovered, through trawling through the logs, that the WSS_Content DB was full!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.