Changing DHCP relay on H3C switch ?

People,

I'm seeking help from you to change the DHCP relay value from the old server IP to the new IP on H3C S5800 Series switch on the below VLAN:

10.1.2.0/24 - Workstation level 1
10.1.3.0/24 - Wireless LAN level 1
10.1.4.0/24 - Workstation level 2
10.1.5.0/24 - Wireless LAN level 2

Old DHCP server IP: 10.1.3.2
New DHCP server IP: 10.1.3.196

but still not sure how to do it and what could be the impact for the production network traffic flow.

Does it requires switch restart or reboot ?

KB article: http://www.h3c.com/portal/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5800_Series_Switches/#Configuration

Thanks
LVL 9
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Here are the result of display running-config result:

******************************************************************************
* Copyright (c) 2004-2011 Hangzhou H3C Tech. Co., Ltd. All rights reserved.  *
* Without the owner's prior written consent,                                 *
* no decompiling or reverse-engineering shall be allowed.                    *
******************************************************************************

User interface aux0 is available.

Please press ENTER.


Login authentication


<CORE-SWITCH01>display current-configuration
#
 version 5.20, Release 1211
#
 sysname CORE-SWITCH01
#
 clock timezone #Web#10#02 add 10:00:00
#
 super password level 3 cipher ISqbSaL!#%&#@!!!
#
 dhcp relay server-group 1 ip 10.1.3.2
#
 irf domain 2
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 32
 irf member 2 priority 31
#
 domain default enable system
#
 telnet server enable
#
 irf-port load-sharing mode destination-mac source-mac
#
vlan 1
 name Infrastructure_Both_DC's
#
vlan 2
 name Servers
#
vlan 3
 name Servers_&_Workstations
#
vlan 4
 name Workstations
#
vlan 5
 name IPTelephony
#
vlan 6
 name Infrastructure
#
vlan 7
 name VMotion
#
vlan 8
 name Workstations_VLAN8
#
vlan 9
 name Guest_Wireless
#
vlan 10 to 17
#
vlan 18
 name IPTelephony_VLAN18
#
vlan 19 to 29
#
vlan 30
 name CDP
#
vlan 31 to 60
#
vlan 61
 name TEMP_IP_TELEPHONY
#
vlan 62 to 239
#
vlan 240
 name DMZ
#
vlan 241 to 4094
#
radius scheme system
 server-type extended
 primary authentication 127.0.0.1 1645
 primary accounting 127.0.0.1 1646
 user-name-format without-domain
#
domain system
 authentication login local
 access-limit disable
 state active
 idle-cut disable
 self-service-url disable
#
user-group system
#
local-user admin
 password cipher IJKSAaL'1*@*#$&^$MAX5<1!!
 authorization-attribute level 3
 service-type ssh telnet terminal
#
 stp instance 0 priority 61440
 stp enable
#
interface Bridge-Aggregation1
 description HQ-SWITCH01
 port link-type trunk
 port trunk permit vlan 1 to 5 9 102
 link-aggregation mode dynamic
#
interface Bridge-Aggregation2
 description HQ-SWITCH02
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation3
 description HQ-SWITCH03
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation4
 description HQ-SWITCH04
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation5
 description HQ-SWITCH05
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation6
 description HQ-SWITCH06
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation7
 description HQ-SWITCH07
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 link-aggregation mode dynamic
#
interface Bridge-Aggregation8
 description PRODBU LACP
 port access vlan 3
 link-aggregation mode dynamic
#
interface Bridge-Aggregation9
 description HQ-NEW-OFFICE-SW1
 port link-type trunk
 port trunk permit vlan 1 to 5 8 to 9 18 61
 link-aggregation mode dynamic
 stp root-protection
#
interface Bridge-Aggregation18
 description HQ-SWITCH08
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 link-aggregation mode dynamic
#
interface Bridge-Aggregation19
 description HQ-SWITCH09
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 link-aggregation mode dynamic
#
interface Bridge-Aggregation101
 description LACP_to_DC
 port link-type trunk
 port trunk permit vlan 1 to 2 9 30
 link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface1
 ip address 10.1.1.3 255.255.255.128
 vrrp vrid 1 virtual-ip 10.1.1.1
 vrrp vrid 1 priority 200
 vrrp vrid 1 preempt-mode timer delay 30
 vrrp vrid 1 authentication-mode md5 _IG5C=\A%A#Q=^Q`HSF4<1!!
#
interface Vlan-interface2
 ip address 10.1.2.232 255.255.255.0
#
interface Vlan-interface3
 ip address 10.1.3.250 255.255.255.0
#
interface Vlan-interface4
 ip address 10.1.4.250 255.255.255.0
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface5
 ip address 10.1.5.250 255.255.255.0
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface6
 ip address 10.1.6.250 255.255.255.0
#
interface Vlan-interface8
 ip address 10.1.8.250 255.255.255.0
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface18
 ip address 10.1.18.250 255.255.255.0
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface61
 ip address 10.1.61.250 255.255.255.0
 dhcp select relay
 dhcp relay server-select 1
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 description HQ-SWITCH01 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9 102
 port link-aggregation group 1
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 description HQ-SWITCH02 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 2
#
interface GigabitEthernet1/0/3
 port link-mode bridge
 description HQ-SWITCH03 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 3
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 description HQ-SWITCH04 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 4
#
interface GigabitEthernet1/0/5
 port link-mode bridge
 description HQ-SWITCH05 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 5
#
interface GigabitEthernet1/0/6
 port link-mode bridge
 description HQ-SWITCH06 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 6
#
interface GigabitEthernet1/0/7
 port link-mode bridge
 description HQ-SWITCH07 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 7
#
interface GigabitEthernet1/0/8
 port link-mode bridge
 description VLAN 3 Access Port
 port access vlan 3
#
interface GigabitEthernet1/0/9
 port link-mode bridge
 description PRODESX03 PCI3.1
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet1/0/10
 port link-mode bridge
 description PRODESX04-OB2
 port link-type trunk
 port trunk permit vlan 1 6
#
interface GigabitEthernet1/0/11
 port link-mode bridge
 description HQ-SWITCH09 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 port link-aggregation group 19
#
interface GigabitEthernet1/0/12
 port link-mode bridge
 description PRODESX02 OB1
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet1/0/13
 port link-mode bridge
 description HQ-SWITCH08 1/0/47
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 port link-aggregation group 18
#
interface GigabitEthernet1/0/14
 port link-mode bridge
 description PRODESX01 OB1
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/15
 port link-mode bridge
 description PRODESX01 OB4
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/16
 port link-mode bridge
 description PRODESX02 OB4
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/17
 port link-mode bridge
 description PRODESX03 OB1
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/18
 port link-mode bridge
 description PRODESX03 OB4
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/19
 port link-mode bridge
 description PRODESX01 PCI3.1
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/20
 port link-mode bridge
 description PRODESX02 PCI3.1
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/21
 port link-mode bridge
 description PRODBU2
 port access vlan 3
 stp edged-port enable
#
interface GigabitEthernet1/0/22
 port link-mode bridge
 description PRODESX01 PCI3.0
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet1/0/23
 port link-mode bridge
 description PRODBU OB1
 port access vlan 3
 stp edged-port enable
 port link-aggregation group 8
#
interface GigabitEthernet1/0/24
 port link-mode bridge
 description PRODESX03 ILO
 port access vlan 6
 stp edged-port enable
#
interface GigabitEthernet2/0/1
 port link-mode bridge
 description HQ-SWITCH01 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9 102
 port link-aggregation group 1
#
interface GigabitEthernet2/0/2
 port link-mode bridge
 description HQ-SWITCH02 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 2
#
interface GigabitEthernet2/0/3
 port link-mode bridge
 description HQ-SWITCH03 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 3
#
interface GigabitEthernet2/0/4
 port link-mode bridge
 description HQ-SWITCH04 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 4
#
interface GigabitEthernet2/0/5
 port link-mode bridge
 description HQ-SWITCH05 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 5
#
interface GigabitEthernet2/0/6
 port link-mode bridge
 description HQ-SWITCH06 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 6
#
interface GigabitEthernet2/0/7
 port link-mode bridge
 description HQ-SWITCH07 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 9
 port link-aggregation group 7
#
interface GigabitEthernet2/0/8
 port link-mode bridge
 description HQ-SWITCH09 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 port link-aggregation group 19
#
interface GigabitEthernet2/0/9
 port link-mode bridge
 description PRODESX03 OB2
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet2/0/10
 port link-mode bridge
 description PRODESX02-PCI3.0
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet2/0/11
 port link-mode bridge
 description HOEVAP6300 MM
 port access vlan 6
#
interface GigabitEthernet2/0/12
 port link-mode bridge
 description PRODESX01 OB3
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet2/0/13
 port link-mode bridge
 description HQ-SWITCH08 1/0/48
 port link-type trunk
 port trunk permit vlan 1 to 5 8 18
 port link-aggregation group 18
#
interface GigabitEthernet2/0/14
 port link-mode bridge
 description PRODBU iLO
 port access vlan 6
 stp edged-port enable
#
interface GigabitEthernet2/0/15
 port link-mode bridge
 description Tape Library
 port access vlan 6
 stp edged-port enable
#
interface GigabitEthernet2/0/16
 port link-mode bridge
 description PRODESX03 PCI3.0
 port link-type trunk
 port trunk permit vlan all
#
interface GigabitEthernet2/0/17
 port link-mode bridge
 description PRODESX02 OB3
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet2/0/18
 port link-mode bridge
 description PRODESX03 OB3
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet2/0/19
 port link-mode bridge
 description PRODESX01 OB2
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet2/0/20
 port link-mode bridge
 description PRODESX02 OB2
 port link-type trunk
 port trunk permit vlan all
 stp edged-port enable
#
interface GigabitEthernet2/0/21
 port link-mode bridge
 description PRODESX01 ILO
 port access vlan 6
 stp edged-port enable
#
interface GigabitEthernet2/0/22
 port link-mode bridge
 description PRODESX02 ILO
 port access vlan 6
 stp edged-port enable
#
interface GigabitEthernet2/0/23
 port link-mode bridge
 description PRODBU OB2
 port access vlan 3
 stp edged-port enable
 port link-aggregation group 8
#
interface GigabitEthernet2/0/24
 port link-mode bridge
 description PRODBU2
 port access vlan 3
 stp edged-port enable
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/25
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 to 2 9 30
 port link-aggregation group 101
#
interface Ten-GigabitEthernet1/0/26
 port link-mode bridge
 description HQ-NEW-OFFICE-SW1
 port link-type trunk
 port trunk permit vlan 1 to 5 8 to 9 18 61
 stp root-protection
 port link-aggregation group 9
#
interface Ten-GigabitEthernet2/0/25
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 to 2 9 30
 port link-aggregation group 101
#
interface Ten-GigabitEthernet2/0/26
 port link-mode bridge
 description HQ-NEW-OFFICE-SW1
 port link-type trunk
 port trunk permit vlan 1 to 5 8 to 9 18 61
 stp root-protection
 port link-aggregation group 9
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
interface Ten-GigabitEthernet2/0/27
#
interface Ten-GigabitEthernet2/0/28
#
ospf 100 router-id 10.1.1.3
 silent-interface Vlan-interface2
 silent-interface Vlan-interface4
 silent-interface Vlan-interface5
 silent-interface Vlan-interface6
 silent-interface Vlan-interface8
 silent-interface Vlan-interface18
 area 0.0.0.0
  network 10.1.0.0 0.0.255.255
#
 dhcp enable
#
 ntp-service source-interface Vlan-interface2
 ntp-service unicast-server 10.1.3.26
#
 ssh server enable
#
 undo arp check enable
#
 load xml-configuration
#
 load tr069-configuration
#
user-interface aux 0 1
 authentication-mode scheme
user-interface vty 0 15
 authentication-mode scheme
#
irf-port 1/2
 port group interface Ten-GigabitEthernet1/0/27 mode enhanced
 port group interface Ten-GigabitEthernet1/0/28 mode enhanced
#
irf-port 2/1
 port group interface Ten-GigabitEthernet2/0/27 mode enhanced
 port group interface Ten-GigabitEthernet2/0/28 mode enhanced
#
return
<CORE-SWITCH01>

Open in new window


and this is the DHCP relay value result:

<CORE-SWITCH01>
<CORE-SWITCH01>[b]display dhcp relay all[/b]
    Interface name                                  Server-group
    Vlan-interface4                                       1
    Vlan-interface5                                       1
    Vlan-interface8                                       1
    Vlan-interface18                                      1
    Vlan-interface61                                      1
<CORE-SWITCH01>

Open in new window


For more information.
0
Craig BeckCommented:
You just need to change...

dhcp relay server-group 1 ip 10.1.3.2

Open in new window


...to...

dhcp relay server-group 1 ip 10.1.3.196

Open in new window


That won't impact current traffic and it won't require a reboot either.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Senior IT System EngineerIT ProfessionalAuthor Commented:
Craig,

Thanks for the suggestion so the implementation steps is to issue

first command:
dhcp relay server-group 1 ip 10.1.3.196

what about the second command to delete the existing DHCP relay ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Craig BeckCommented:
Just put the word 'no' at the beginning of the command.
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
THanks !
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
I'm using the web page management console to change the DHCP relay, it's working fine now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.