2 NICS on server. Traffic going ot 2nd Nic

I have 2 NICs in a Windows 2008 R2 server.  Some traffic goes out Guest NIC2 instead of Production NIC1.  Below is what route print shows.  How do you change from Default to a priority metric?  I search Google.  The commands suggested did not work.

Persistent Routes:
  Network Address          Netmask     Gateway Address  Metric
          0.0.0.0                    0.0.0.0        192.168.30.25        Default
          0.0.0.0                    0.0.0.0         172.16.1.35           Default

I want traffic intended for 172.16.1.35 to always go that route.
cvitech08Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark GalvinManaging Director / Principal ConsultantCommented:
Are both NICs on the same LAN?
0
cvitech08Author Commented:
No.  Both NIcs are not on the same LAN.
0
Cliff GaliherCommented:
Did you define a default gatewayvon both NICs? It appears so. Windows (rightfully) complains when you attempt that. Ignoring the warning and proceeding will result in unpredictable behavior.

Only one default gateway. Then define static routes for the other NIC.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

cvitech08Author Commented:
My problem has been defining the static network parameters.

what I tried to configure was the secondary route

route add 0.0.0.0 mask 0.0.0.0 192.168.30.25 Metric 2 IF 2

I also tried to use route change to add Metric 2 IF 2
0
Cliff GaliherCommented:
As long as you have two default gateways specified, that'll supersede any static routes you try to define. You have to fix the one issue before tackling the other.
0
matrix8086Commented:
You need to learn a lot about switching and routing. This is not working as you wish. You must to understand how it is working and use this only in that way.

So: if you have more than 1 NIC on a host, only one NIC can have a default gateway, the rest of NICs must be configured without a default gateway. Change that and if the your problem will not be solved, then:

1. Maybe you left the wrong NIC with the default gateway
2. Maybe you must to implement static route on the clients hosts and not on the router

Best regards!
0
giltjrCommented:
The easiest way to do this, to make sure it is right after a re-boot is to go into the Advanced TCP/IP settings on the LAN adapter on the 172.16.1.0/24  network and make sure it has a default gateway configured pointing to 172.16.1.35.

Then go into Advanced TCP/IP settings on the LAN adapter on the 192.168.30.0/24 network and make sure it has NO default gateway.
0
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.