After airmon-ng cmd, NIC goes offline

This just started happening today, system's wireless is up and running but after entering the airmon-ng start wlan0 cmd, my nic on the laptop goes offline, can't be see by ifconfig.

If I do a airmon-ng afterwards displays:
phy0 wlanmon  Atheros

any ideas?  I'm very new to Linux learning though
TRSTeamAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
You need to make sure your chipset is supported by airmon... Or check if the card is compatible.

In most cases an external compatible USB wifi adapter is recommended to use airmon, something like this for example.

Normally airmon needs to create a secondary wireless nic (called mon0) which will be the monitor... That's probably what's not working.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

From your story we can assume it has worked before right?!
Did you run updates a couple off days ago and if not please try this first.

If you use wifi for internet access and only uses wifi airmon-ng will drop this connection in order to listen to wifi traffic.
TRSTeamAuthor Commented:
Yes I'm been able to run those cmds the last few days, was able to create a .cap file hence the question earlier about crunch cmd but just recently stops, NIC just shuts down.  I have to reboot and can't run the airmon-ng cmds
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Patrick BogersDatacenter platform engineer LindowsCommented:
Is this some Backtrack/Kali distro? If so please run

sudo apt-get update && sudo apt-get upgrade

Finish and try again, still not working? What is the precise error?
TRSTeamAuthor Commented:
Btw was completing this cmd..
crunch 8 12 abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789 | aircrack-ng –bssid 00:11:22:33:44:55 -w- hack-wifi-01.cap

Just needed the airmon-ng for the SSID

very weird, i'd hate to wipe the laptop just for the airmon cmd to start working again
TRSTeamAuthor Commented:
Kali - I've ran the upgrade and update cmds, but not since this recent issue today
Patrick BogersDatacenter platform engineer LindowsCommented:
No need to wipe the entire laptop for just one program.

Lets try deleting airmon-ng and reinstall it.

First:
sudo apt-get remove aircrack-ng

Next:
sudo apt-get install aircrack-ng

If youre Lucky it will work again...
Zephyr ICTCloud ArchitectCommented:
Also try using tools like iwconfig, and try to see if the wlan interface comes back after the command "airmon-ng check kill"
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.