Tomcat 8.0.18 server config files keep reverting to default install settings

Hi all,

I'm having trouble configuring my tomcat 8.0.18 server.

I need to have it SSL enabled and am editing the following files:

* tomcat-users.xml (defining roles and users)
* server.xml (adding a connector to support https access)
* web.xml (defining access controls)

But after applying my settings to these file, what I find is that at some point after re-starting the server, the files revert back to their default tomcat install copies and thus all is lost which I added to them.

I am using Eclipse Lunar and have the Servers project available if that is of any use......

Any helps to solve this is greatly appreciated.
ZuzicAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chaitu chaituCommented:
if make the changes in servers conf files in eclipse then it wont override when you start the server in eclipse
ZuzicAuthor Commented:
I have been editing the server's conf files in eclipse and they still get overwritten on server restart
chaitu chaituCommented:
the one you are changing in eclipse and the one its overriding conf files( i.e.c:\tomcat-8.1.x) looks different.

check the server installation directory by double clicking servers in eclipse.see the screen shot.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZuzicAuthor Commented:
So I have accepted this as the solution - it didn't fully explain to me where I was going wrong (nor could I see the screen shot you mentioned chaitu) but it did make me re-think what I was doing with eclipse.

I was opening the files directly in eclipse from my tomcat conf folder.  but what I was meant to do was open my files from the Servers project in the projects tree in eclipse to edit them from there.

On doing this, my problem is gone :0)

Thanks for the help
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.