Outlook won't load emails unless closed and opened again, or by restarting IIS

Problem Summary:
Outlook won't update unless you close it and open it again. All users in the company experience this issue inside or outside the organisation, but I'm tempted to say it happens more often in the same network as the server (more complaints from users). It also gets fixed when IIS is restarted. Emails flood in but stop again and they do load themselves but you need to wait HOURS!
OWA works fine though, and so does access from mobiles devices.

Full Back Story:
Ok so our server crashed (the C: hard drive failed, only where everything is installed but no actual data is kept). I reinstalled Windows SBS 2008 (ours comes pre-loaded with Exchange 2007). I set up everything as I did 2 years ago when we had other server issues (putting everything the same, from memory). I decided I should write everything down this time just in case, so I have a list of everything I did when installing (if this will be needed).
Everything worked perfectly, but then about a month later a different hard drive failed - this time it was the one that contained all the company data, user data, mailbox's. I restored the data but because of certain factors it was loaded on a new drive letter (R: instead of S:).
Everything works fine except everyone complains that they need to restart outlook to get it to load any new emails or to load any category changes, but OWA works and it loads ok on everyone's mobiles. I presumed it was an issue with IIS, and found that if I restart IIS (restart the web app within the IIS Manager) then all outlooks update. I've also noticed that when I expand the ExAdmin, Exchange, ExchWeb, and Public virtual directories in IIS then it shows an error 'Could not find a part of the path \\.\BackOfficeStorage'
I'm not sure if that error is normal behaviour, but I presume it isn't. I thought it might be something to do with changing the drive letter?

I'm sure the issue clearly lies with SBS 2008 / Exchange itself (not the clients). I've tried best practices analyser and checking error logs but there isn't anything showing up.

Please help me find the problem!!!
sidupacAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Any reason to change drive letter to R:? You should keep the same drive letters, whenever you are recovering exchange server. Also check application and system logs for errors. That might tell  you what issue is going on.
0
sidupacAuthor Commented:
There are some errors in the logs, but nothing seems to be applicable to the problem. Do you want me to provide them?

I restored the mailbox to S: and repaired it in S:, but S: was a partition and once it was recovered I needed to change the partition to the new drive, but the exchange server had already been put online (we needed to begin using it asap) so I started to recover the rest of the company data on the new R: drive while still using S: (it took 2 days to finish restoring!)
Once the restore was fully complete on R: I used the Exchange Management Console to move the Mailbox from S: to R:. There was an error and it didn't mount. I restarted the server and it mounted on R: successfully. I then removed the partition. I have since cleared the logs in an attempt to find any new errors (this was probably a big mistake thinking about it)
0
sidupacAuthor Commented:
let me know which of these you think might be applicable?
or should I just get all the logs??  (takes a while)
1.jpg
2.jpg
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AmitIT ArchitectCommented:
Goto Windows logs>Application logs and system logs.
0
sidupacAuthor Commented:
I'm having trouble uploading it, I exported a .evtx file but the system won't let me upload it. Shall I just take some screenshots or is there another way to get you the lists?   =s
0
sidupacAuthor Commented:
Ok I realised I can just change the export type. I've also filtered it to the last 24 hours. It has definitely occurred multiple times within that time.
24-hours---Windows---Application.txt
24-hours---Windows---System.txt
0
sidupacAuthor Commented:
Ok so I made changes due to Sharepoint errors showing up on the application log, which were "Windows SharePoint Services 3 Search      2424      Gatherer      The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again."
I found this post and followed the steps.
http://blogs.technet.com/b/sbs/archive/2009/05/07/event-2436-for-sharepoint-services-3-search.aspx
I don't seem to be able to access the port :987 at all, not sure I'm meant to be able to??
I also can't open the :4721/_admin/ page that is in the image at the bottom of the technet blog, so not sure if that might be a problem?

I also saw the System error "Microsoft-Windows-DistributedCOM      10016      None      "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{61738644-F196-11D0-9953-00C04FD919C1}"
And made changes according to this post: https://social.msdn.microsoft.com/Forums/vstudio/en-US/883b5f1c-1718-4b9a-a6c8-bf32c5d4d6d2/the-applicationspecific-permission-settings-do-not-grant-local-activation-permission-for-the-com?forum=tfsadmin

Not sure if I'll need to restart the server to finalise anything, but this will happen at the weekend. Now going to wait and see if there is anything else someone can suggest? Otherwise I'll wait and see if the issue persists and let you know.
Maybe you'll want to see more error logs?
0
sidupacAuthor Commented:
Further to this, everything has been running ok for 2 days. I'll report back at the end of the week.
0
sidupacAuthor Commented:
Update - today emails got stuck again. Had to close outlook and reopen again myself, not sure if it happened to anyone else but clearly there is still a problem. I'll go through the logs on my PC and the server to look for errors again. Will try to keep updating on progress.
0
sidupacAuthor Commented:
Ok 4 new errors... but they happened 3am to 5am and the freeze happened at about 4pm

Process MSEXCHANGEADTOPOLOGY (PID=1464). When updating security for a remote procedure call (RPC) access for the Exchange Active Directory Topology service, Exchange could not retrieve the security descriptor for Exchange server object SBS2008 - Error code=80040955.
 The Exchange Active Directory Topology service will continue with limited permissions.

One of the System Attendant's task is blocked.
Function: CPollDomainExchangeServersGroup::Work

#50071: Unable to connect to the database SharePoint_Config_29c26fca-17b8-48c1-9704-b869932abcb6 on SBS2008\Microsoft##SSEE.  Check the database connection information and make sure that the database server is running.

Faulting application SAVFMSESp.exe, version 7.0.2.79, time stamp 0x51f6918a, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x00000008, process id 0x3160, application start time 0x01d09c854c7bdb60.
0
sidupacAuthor Commented:
Ok I think I may have fixed it now. Turns out the OAB was not synchronising and this is the point where it got 'stuck' which is why restarting Outlook worked. I followed the instructions here to get it to work (which was add read permissions to the OAB web.config file)
http://andywolf.com/exchange-2010-offline-address-book-oab-will-not-download/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sidupacAuthor Commented:
I had to work out the problem myself. Google and thinking got the problem solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.