Timeserver on DC always 3 Minutes ahead

Hello,
I'm going crazy with my Domaincontrollers Timesetting. The Time is always 3 Minutes ahead even after I used all recommended ways to fix it, like:
https://support.microsoft.com/en-us/kb/816042#LetMeFixItMyselfAlways2
I used both ways, manual and the fixit tool.

I checked the event logs on the server, theres also no error to find.
It tells me that the the server receives the time from my external pool of timeserver.
BUT, all machines keeping the wrong time with exactly 3 Minutes ahead from the devices like Firewall that are getting the time from the same external sources!

Any Idea????

Bernhard
Bernhard KanduthAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

matrix8086Commented:
In DC with FSMO role run from cmd:

 w32tm /register /config /manualpeerlist:"external_ntp_server" /syncfromflags:MANUAL

 This will register NTP as service and will syncronize domain clock with an ntp external server (time.windows.com, or pool.ntp.org, etc. You can add more servers between quotes separated by space)

 On the server which are not DC's, or workstations, from cmd run:

 w32tm [/register] /config /syncfromflags:DOMAINHIER

For more information check below

https://technet.microsoft.com/en-us/library/w32tm.aspx

If this will not solve your problem, it means your firewall block UDP traffic for ntp requests or ntp responses to/from external time servers (UDP port 123)

 Best regards!
0
Patrick BogersDatacenter platform engineer LindowsCommented:
I agree Matrix8086.

There could be another culprit and thats applicable IF your mail domain controller (PDC) is a virtual machine. Then you can configure whatever you want but probably the hyper visor arranges the time which you can disable on that level.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bernhard KanduthAuthor Commented:
Thank you both,
Patricksr1972, you hit the Nail, since the DC is on a Hyper-V I only needed to fix it on the Host :-)
Best regards!
Bernhard
0
Patrick BogersDatacenter platform engineer LindowsCommented:
Nice!!
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Actually, you should disable timesync with the host.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.