Client updates fail from WSUS

I am currently having some issues with some of the Clients on my network. They will not update from the WSUS. The clients are reporting back but when the user is logged onto the computer they will receive a message stating that there are updates available. When i try and update them they fail.  I've looked and they are 32 bit updates for a 32 bit program on a 64 bit O.S. also i have checked that the GPO is working correctly and they should be auto updating however this isn't the case.  I ran a Sfc /scannow and there were some corrupt files and im not sure how to fix them.  Im looking for a lot of help and i realize this but im hoping this is all due to one issue that i cant pin point.
CBS.log
failed-updates.png
failed-updates-2.png
Korey DavisHelp DeskAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cwstad2Commented:
you can also try and run this on the failed computer from a batch file. This will reset WSUS on that computer

@echo off
net stop wuauserv
 rmdir %windir%\softwaredistribution /s /q
 rmdir %windir%\system32\softwaredistribution /s /q
 regsvr32 /s wuaueng.dll
 regsvr32 /s wuaueng1.dll
 regsvr32 /s atl.dll
 regsvr32 /s wups.dll
 regsvr32 /s wups2.dll
 regsvr32 /s wuweb.dll
 regsvr32 /s wucltui.dll
 net start wuauserv
 pause
Korey DavisHelp DeskAuthor Commented:
i tried the batch file and it didnt do anything.  still showing failed updates.
Seth SimmonsSr. Systems AdministratorCommented:
I ran a Sfc /scannow and there were some corrupt files and im not sure how to fix them.

what were the results of the scan? did it say it couldn't fix anything?
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Korey DavisHelp DeskAuthor Commented:
the results are attached already. They are labeled CBS. It will show the entire results to the scan.

i will take a look at the hot fixes.
Korey DavisHelp DeskAuthor Commented:
that hotfix is already installed on the computer.
jcimarronCommented:
Korey Davis --
Try installing these updates one by one.

If no help, Scan for viruses and malware.

Run the WindowsUpdateDiagnostic.diagcab
https://support.microsoft.com/en-us/kb/910336/en-us

Look at your third screenshot.  You are offered "More Information" in the right panel.  Click on that and make sure the update applies to your PC, or whether it is necessary based on your experience.  (Windows Update sometimes offers Updates which are not needed.)
If not, right click and Hide it.
Korey DavisHelp DeskAuthor Commented:
i have tried running the updates one by one and that failed as well. I also checked the other computers that are failing and noticed all of them are the exact same updates. Can it be the clients and not the WSUS?
jcimarronCommented:
Korey Davis--
"Can it be the clients "
If by clients you mean the Updates, that is part of what I suggested.  Something is not right with the Updates.  Did you look into "More Information" for each update?
Korey DavisHelp DeskAuthor Commented:
I did Look into the "More Information" and they seem to be needed for the computer im on. I tried manually downloading the update from Microsoft and it still failed.
.-net-framework-2.png
.net-framework.png
jcimarronCommented:
Korey Davis--
Your latest screenshots concern .NET Framework.  Earlier you said the problem was with various Office 2013 apps.  I am confused.  These .NET Framework screenshots show no problem.

Screenshot .NET Framework2.png shows that Silverlight is outdated.  Have you updated?

Did you read about the prerequisite when installing KB2956177?  And determining whether you are running the Click to Run or .msi-based Office 2013?

kb2956174 also requires prerequisites.
Korey DavisHelp DeskAuthor Commented:
Im sorry for the confusion. Im having a few issues. The .net framework was not installing as well as the office updates. Some computers will show that .Net framework failed and others show three office updates failing. As for the .net framework updates i updated everything and they still failed to download.  

To narrow it down it doesnt seem to be the WSUS it seems to be something with the clients. They are not allowing updates to download.  Right now i am uninstalling any applications that are not being used.
jcimarronCommented:
Korey Davis--
I assume you have successfully installed other downloads (Updates and others) recently.  That would knock out problems with WSUS.  If not let us know.  (I have a whole bunch of fixes for Windows Update.  :) )

Did you install the prerequisites I mentioned earlier?

Check what else is running with Process Explorer.
http://technet.microsoft.com/en-us/sysinternals/bb896653

I understand you have run scans for virus and malware.

I do not see any corrupt files in the CBS.log.  Rather I see a lot of errors "Failed to internally open package".

There was a thread on E-E about a year ago.  The bottom line was to run a Repair Install.
http://www.sevenforums.com/tutorials/3413-repair-install.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Korey DavisHelp DeskAuthor Commented:
sorry i have to re-word this i was in a rush responding.
I have successfully installed other downloads on other computers in the same location recently.
Also i don't see any prerequisites for this update. Im assuming it should be ok.
 
Im leaning away from the WSUS now however the computers are failing to download the updates.

Scanning for Viruses and malware has been done and nothing was wrong.

When you look at the CBS. log  what does that error mean? "Failed to internally open package"?  is this something with windows or is a program blocking it?

Also i was taking a look at the repair on windows link.  How would several computers (5-7 depending on location) OS become corrupt to not download the exact same updates? Im stumped here.  

What ive already done:
-Updated the WSUS and sifted through all the updates and allowed all security and critical updates that pertain to our Network
-Checked the GPO for updating
-tested the settings on WSUS
-Manually tried downloading updates from Microsoft directly to the client computers.
-Uninstalled WSUS and reinstalled it
-Ran Command script to see if the Client could contact the WSUS
I would like to see if i can fix the problem without trying to run a repair on windows.
Seth SimmonsSr. Systems AdministratorCommented:
have you tried disabling anti-virus then run the update?

have you tried downloading the updates manually?
the first one is 2956174

Update for Microsoft Lync 2013 (KB2956174) 32-Bit Edition
https://www.microsoft.com/en-us/download/details.aspx?id=46316

just about all windows updates are silent installs so you won't see any error messages
it should show something useful when doing it manually interactive
Korey DavisHelp DeskAuthor Commented:
I have tried updating them manually and they failed. however i tried fixing the install of Office on once computer and all 6 updates completed with no errors. Im thinking i may have found the solution. But still testing it. I was told this shouldn't be the case so i never tried it until now.
Korey DavisHelp DeskAuthor Commented:
Found the solution to the updates. So i was thinking it was the WSUS but it never was the issue. I manually tried updating them and they would still fail. so upon a little more research and doing trial and error i found that the program needed to be repaired. I went into control panel and repaired the program then tried updates again. The updates started and completed without any errors.
Korey DavisHelp DeskAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for Korey Davis's comment #a40804992

for the following reason:

I found the problem with the help of the members and some online research.
jcimarronCommented:
Korey Davis--
Does this also fix the problem with .Net Framework?
Korey DavisHelp DeskAuthor Commented:
the .Net framework error is no longer showing on any of the computers. I'm not sure if my supervisor found a fix for that or if they got installed when the repair was done on the program.
cwstad2Commented:
Glad we were of some help.  Don't forget to score members who helped towards your resolution
Korey DavisHelp DeskAuthor Commented:
helped point me in the right direction.
jcimarronCommented:
Korey Davis--
Glad to have helped!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.