TightVNC Connection Problem

I have the latest version of TightVNC installed on a workstation.  For some reason, I cannot connect to this machine.  I can connect via RDP just fine.  I have tried uninstalling TightVNC and reinstalling.  Same problem.  TightVNC taskbar icon says it is listening for connections, but I cannot connect.  Tried connecting from multiple workstations. Firewall exceptions for TightVNC are in place.  I have also completely disabled the firewall- still unable to connect.  Machine in question is not "listening" on port 5900 (verified through Test-NetConnection in Powershell).  Tried switching to a different port. Connection problem persists.    Any idea how to resolve this problem?
arkhaminmate11nAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davy ParidaensCommented:
You need to forward the following ports 5800 and 5900 tcpon your router and Firewall.

grtz

Davy
0
arkhaminmate11nAuthor Commented:
These machines are on a LAN.  So no router or firewall- just a switch.
0
CompProbSolvCommented:
What happens if you try to use the computer to connect to itself with VNC?  Don't type the password in, just see if it asks for one.

I'd be most suspicious of the firewall, though your comment about the problem persisting while the firewall was disabled says that should not be the issue.  Are you sure it is disabled for the type of network connection (Public, Private, etc.) that is being used?  I have resorted to permitting the specific port in Windows Firewall in order to get VNC to work.

Can you show the results of your Test-Netconnection?  I tried it on my computer (with VNC server properly working) and I get "False" for TcpTestSucceeded.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

arkhaminmate11nAuthor Commented:
I use GPO to deploy Windows Firewall settings.  All machines that are being controlled by the "Windows Firewall GPO" have no problem with VNC connectivity.  Again, I did go into Windows services and completely disable the Windows firewall.  Problem with VNC connectivity persisted.

Here are the PowerShell results:

First is the problem machine.  Second is a machine that is working.

Windows PowerShell
Copyright (C) 2014 Microsoft Corporation. All rights reserved.

PS C:\windows\system32> Test-NetConnection co-ws42 -Port 5900
WARNING: TCP connect to co-ws42:5900 failed


ComputerName           : co-ws42
RemoteAddress          : 10.0.20.169
RemotePort             : 5900
InterfaceAlias         : Ethernet
SourceAddress          : 10.0.20.87
PingSucceeded          : True
PingReplyDetails (RTT) : 0 ms
TcpTestSucceeded       : False



PS C:\windows\system32> Test-NetConnection co-ws09 -Port 5900


ComputerName           : co-ws09
RemoteAddress          : 10.0.20.82
RemotePort             : 5900
InterfaceAlias         : Ethernet
SourceAddress          : 10.0.20.87
PingSucceeded          : True
PingReplyDetails (RTT) : 1 ms
TcpTestSucceeded       : True



PS C:\windows\system32>
0
CompProbSolvCommented:
I was in error about Test-NetConnection on my computer.  I have results similar to your "good" one.

Did you try having the machine connect to itself with VNC?  I'm presuming that it will also fail.

Any chance there is some other firewall present?
0
arkhaminmate11nAuthor Commented:
I cannot test connecting to the machine from the machine as a user is currently using the machine.

No other firewall present.
0
CompProbSolvCommented:
I am somewhat stumped on this one.

I'd try one other thing.  Disable RDP (and confirm that the computer can no longer be reached by RDP), change the VNC port to 3389, then try to connect to the computer with VNC on 3389.
0
arkhaminmate11nAuthor Commented:
Thanks.  Will do.
0
arkhaminmate11nAuthor Commented:
I am not sure why or how, but the problem resolved itself.  Prior to the resolution, all I did was disable the firewall, reboot, found the connection failed again, I then re-enabled the firewall, rebooted, and found the connection worked after this sequence of events.  So maybe something got 'hung' up in the firewall?  Anyway, thanks for the help.
0
CompProbSolvCommented:
I agree that it was likely something odd with the firewall.  The part that is surprising is that it interfered when the service was stopped.  That it blocked VNC even while it was configured to allow it is not nearly as surprising.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.