ActiveSync Issues - Sync limit?

I have has this issue a good couple of months now and it is proving difficult to get to the bottom of..

Setup
Exchange 2003 SP2 FE
Exchange 2003 SP2 BE x 4

ActiveSync works on ALL exchange servers however there seems to be an issue on all but one of the servers where devices will fall out of sync. We have tested this to exhaustion and have come up with the following trends

New mailboxes sync ok and continue to sync as long as a particular sync doesn't contain more that 30,000 chars, this can be one email or multiple emails. Removing the suspect email(s) from the mailbox via outlook means the sync works again until more large emails are received

Existing mailboxes sync depending on the contents of a mailbox, eg my mailbox will only sync folders and no content, if I delete all emails then sync works until a large email is received.

This pattern is the same across all BE servers expect one, on this working server ExchBE01 ActiveSync works regardless of the mailbox content

If I run an exchange connectivity test on a mailbox on either ExchBE02-04 which contains large emails all tests pass expect the item sync which times out..

There is currently no desire on this platform to upgrade exchange OR add an alternative solution (as much as I would love to!)

Any ideas?
LVL 8
StuartTechnical Architect - CloudAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
There has to be something different between the servers.
Network card drivers, network connectivity etc. Something like that.
Could be AV software scanning something it shouldn't be.

Although I am seeing more problems with Exchange 2003 ActiveSync than ever - and I put that down to its age. The modern ActiveSync versions are simply not tested with 2003, so will start to do things that 2003 cannot understand or cope with.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
StuartTechnical Architect - CloudAuthor Commented:
Thanks for your comments Simon, you are correct the servers are different some virtual some physical, different patch levels etc I put that as well as several other factors down to why this is not working as expected. The time and effort I would have to spend to resolve this is not worth it. Thanks again :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.