Cannot Load "PROGRA~1\MICROS~2.0|Common7\Packages\FPACUT~1.DLL"

I get the below error every time i try to switch to Design View in my Visual Studio website.  Any Ideas?

Cannot Load "PROGRA~1\MICROS~2.0|Common7\Packages\FPACUT~1.DLL"
garyrobbinsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob LearnedCommented:
1) FPACUTIL10.DLL is the Web Authoring Component DLL.  

2) Do you see something like these values in the PATH environment variable?

C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Packages
C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Packages\vwd
garyrobbinsAuthor Commented:
I have the below

C:\Program Files\Microsoft Visual Studio 11.0\Common7\Packages
C:\Program Files\Microsoft Visual Studio 11.0\Common7\Packages\vwd

I have tried uninstalling and redownload but get the same error
Bob LearnedCommented:
Does the error message mention anything about writing a log file?

Try this if it doesn't:

Visual Studio Package Load Failures - What's wrong with my package?
http://blogs.msdn.com/b/edhintz/archive/2006/10/23/visual-studio-package-load-failures-what-s-wrong-with-my-package.aspx
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

sarabandeCommented:
what platform you are working on? it should be a 32-bit windows because on a 64-bit windows visual studio must be installed below

C:\Program Files (x86)\Microsoft Visual Studio 11.0\...

(as Bob has posted) since visual studio is a 32-bit application.

if you are on 32-bit windows are the directories you posted existing on your disk and can you answer the question Bob has asked whether the 'FPACUTIL10.DLL' was existing?

Sara
garyrobbinsAuthor Commented:
Applogies, I got pulled away and had to leave this on the back burner. Could not locate FPACUTIL10.DLL on my computer

I am using 32- bit lap top.
sarabandeCommented:
what variant of visual studio 2012 did you install?

did you add web authoring when installing the visual studio?

Sara
garyrobbinsAuthor Commented:
Ultimate,  I tried to add web authorizing but it said I already had it.
sarabandeCommented:
i found a site which states that the dll is fpacutl.dll and not fpacutil10.dll  (at least if the web authorizing component was installed separately). i have visual studio 10 and i found fpacutl10.dll below C:\Program Files (x86)\Microsoft Visual Studio 10.0> since i work at win7 64-bit.

the 8.3 filename fpacut~1.dll can mean both. you may open a command window (by cmd after win+R) and type

cd \
dir /s fpacut~?.dll

Open in new window


this should output some hits below C:\Program Files\Microsoft Visual Studio 11.0\Common7\Packages. if there are other folders as well (for example a folder below microsoft office installation folder), the problem could be that your setup has made a new short name fapacut~2.dll and therefore the fpacut~1.dll couldn't be loaded.

to verifiy this, repeat the dir command in the command window but add /x
dir /s fpacut~?.dll /x

Open in new window


now the output should show the short names rather the long names.

if some of these suppositions were true, you could try to uninstall the web authorizing tool. after uninstalling, check again whether still files fpacutl*.dll files exist. if yes, rename them by adding a 'x' prefix. that way the short name fpacut~1.dll could no longer be found and perhaps the issue is fixed after reinstallation.

Sara

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
garyrobbinsAuthor Commented:
Not sure how, but this seems to have fixed it thank you very much for your assistance
sarabandeCommented:
Not sure how
actually, i have no idea why the visual studio loader uses short filenames for to load the web authorizing component. the last digit of the short name was automatically incremented when a file was created. so if you already have the same long name file already installed somehow, the new copy would get fpacutl~2.dll. hence, the same long file name may have different short names depending on whether there are already files beginning with the same 6 characters or not. i assume the ambiguouty arised after a second installation of the tool what changed the short file name but not the path stored in the settings of visual studio. i am happy that reinstallation solved the issue.

Sara
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual C++.NET

From novice to tech pro — start learning today.