FileIO test NFS mount

I am conducting a POC against a few popular NAS filer systems (1st example runs ZFS) and I wish to use FIO to test remote throughput, latency, etc. I'm relatively new to Linux.
I mounted the remote system as an NFS mount and then am attempting to run FIO against it using options as follows:
"fio --directory=./ --rw=randwrite --bs=4k --rwmixread=100 --iodepth=1 --numbobs=1 --name=4ktestwrite --size ==100M"

Any FIO experts out there that can walk me through some of these parameters and/or discuss some reasonable FIO tests against ZFS NAS?

Thanks.
SaffronThePuppyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

robocatCommented:
Benchmarking requires that you know the IO requirements of the application that you will run on the NAS.

E.g. databases or VMWare require mainly random IO, file sharing of large multimedia files requires mainly sequential IO. You also need to know the number of simultaneous users/processes accessing the NAS, blocksize of the average IO request,...

You can only perform a valid benchmark if you know this info. Then you can use a tool like FIO to mimic the real world usage and get results that have actual meaning.

If you can provide this type of info, I can help to translate this into FIO options.
0
robocatCommented:
Any thoughts ?
0
SaffronThePuppyAuthor Commented:
Here are the reqs I received. I'm still trying to understand exactly what they want to get from this but here we go.
The key is that this is for an NFS target.

Test 1
1 LUN with Threads:16, Queue Depth:16
IOPS, Avg Latency, Max Latency, standard deviation at 100% read, 100% write at variable block sizes.
Block Sizes (KB): 4,8,16,32,64,128
Test 2
2 LUN sizes with IOPS, Avg Latency, Max Latency, Standard Deviation at 70% Read/30% Write
2 threads
2,4,8,16 Queue Depth
4 threads
2,4,8,16 Queue Depth
8 threads
2,4,8,16 Queue Depth
16 threads
2,4,8,16 Queue Depth
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

robocatCommented:
I'm not sure where you got this from ??

Testing LUNs with various queue depths etc. is a whole different story and all this makes no sense for the question you're asking.

The danger of synthetic benchmark testing is that you do this without knowing the real world requirements. Some devices will perform well for one task and not for the other and vice versa, often there's not "best" choice in general.

So info needed:

- what's the application (RDBMS, file server, VMWare, ...)
- average block size ("variable block sizes" is not the answer)
- average number of simultaneous users/processes
- average % of reads and writes
- average % of random versus sequential
0
SaffronThePuppyAuthor Commented:
I understand what you're getting at and thank you for responding. In this case it's a standardized/canned test which I was given and I have no background knowledge of the customer or specific application's IO profile.
I would settle for this:
How do I run fio against a directory and not a device. I need to run it against /mnt/nfs   as opposed to /dev/sdb  /dev/sdc ..
If I can get this running, I can ask more intelligent questions.

The following syntax fails:

fio --filename=/mnt/NFS --rw=randrw --ioengine=libaio --bs=4k --rwmixread=1-- --iodepth=2 --numjobs=1 --runtime=2 --group_reporting --name=4ktest

return: "fio: pid=10709, err=21/file:filesetup.c:573, func=open(/mnt/NFS), error=Is a directory"
0
robocatCommented:
--filename requires a filename, not a directory or mount point. Just eliminate this parameter. Specify the test directory with --directory=/mnt/NFS
If no directory is specified, the test will run in the current directory.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SaffronThePuppyAuthor Commented:
makes sense. And this worked below:
fio --rw=randrw --ioengine=libaio --bs=64 --rwmixread=30 --iodepth=6 --numjobs=5 --runtime=30 --name=4ktest --size=64 --output=out1

thanks robocat
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.