RIP WAN Advertising Default Route BSD/Unix

We're trying to implement a RIP WAN where Site A is the only internet facing site.

We use pfSense firewalls across all sites which are BSD based, the standard BSD RIP Daemon 'routed' is install and enabled.

Site A is advertising all of its routes correctly except for the default route and I'm completely stumped on how to get this to work correctly.

I've tried things such as
root@localhost: routed -g
~ routed -F 0/0,1
Adding fake_default=1 to /etc/gateways

If I try to do something like adding this to /etc/gateways
net 0.0.0.0 gateway 172.22.0.14 metric 1 active

I get a bad net message saying I can't have that as the default route which is confusing as I can find a few people that have used something like that as an example or in lab scenarios.

Cisco routers have the "default-originate" command which takes care of this function and from reading the routed(8) article on the BSD page it would appear that "routed -g" SHOULD do the same but using this option seems to do nothing.

Am I missing something here? Or are there more hoops to jump through to get this default route to go out?
auscomAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Usually you need a mask/netmask net 0.0.0.0 mask 0.0.0.0
Not sure whether CIDR notation 0.0.0.0/0 will be accepted.
auscomAuthor Commented:
Example from BSD page
net Nname[/mask] gateway Gname metric value <passive | active | extern>

Have tried
net 0.0.0.0/0.0.0.0 gateway 172.22.0.14 metric 1 active
net 0.0.0.0 mask 0.0.0.0 gateway 172.22.0.14 metric 1 active

Also tried playing with the subnet parameter: subnet=nname[/mask][,metric]
subnet=0.0.0.0/0.0.0.0,1
subnet=0.0.0.0/0,1

All with no luck when starting up the routed daemon it reports there is a bad line in /etc/gateways

If I add to Site B's /etc/gateways
net 0/0 gateway 172.22.0.5 metric 1 active

This seems to be the correct format as it accepts the line but then reports
bad net "0/0" in /etc/gateways entry "net 0/0 gateway 172.22.0.5 metric 1 active"--cannot be default
arnoldCommented:
Look at routed manual pages section 8.

One option in addition to using -g to include snippet from the manual page
-P pm_rdisc on the command line or pm_rdisc in the /etc/gateways file.

I think this is what you are looking for either use the -P pm_rdisc or just add pm_rdisc into the gateways file.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
auscomAuthor Commented:
Ah I was thrown off a little bit from the manual, the description of pm_rdisc refers to broadcasting a default route for RIPv1 and I did not try playing with this switch.

This with a combination of an outbound NAT entry and internet traffic is now flowing as it should.

Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.