How to make the T/S defautl printer the default printer for RDP users?

We have a 2008 terminal server installed with a "PDF Creator" printer. We want all Remote Desktop uses who connects to this terminal server will automatically have the "PDF Creator" printer as the default printer no matter which default printer they have in their local.
The current situation is, after they get connected, whichever printer they have as default on their local computer will become the default on the remote access session.
Please help.
CastlewoodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Spike99On-Site IT TechnicianCommented:
I would make sure the "default to main client printer" option is NOT set in TSconfig.
1.  Click on Start > Run
2.  Type in tsconfig.msc & press enter to run TS Configuration Manager
3.  Right click on the connection name (like RDP-TCP)
4.  Click on Properties
5.  Under the client settings tab, be sure that the "default to main client printer" isn't selected: uncheck that option if it is
6.  Close the TSConfig console to apply the setting

This setting will only apply to new RDP connections, not existing TS Sessions.  So, users will need to log off the server & back on to see the change (clicking "X" to close the RDP window will just disconnect their session, not log them off: they need to log off & then back on).

Then, make sure that PDF printer is set as the default on the 2008 server.

That should set that PDF printer as their unless there is another printer on the server that pops up as their default because of something in their profile.  If that's the case, you can force that PDF printer to be their default printer by running a batch file at log on with this line:
RUNDLL32 PRINTUI.DLL,PrintUIEntry /y /n "Printer Name"

Substitute the name of the PDF printer where it says Printer Name above.  I would copy that  BAT file to the "Startup" group in Server 2008 so it runs for all users at logon. Or, you could add that as a logon script using a GPO.

The startup folder for all users in Windows Server 2008 is:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

I hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.