urlmon.dll errors win 7

keep getting urlmon.dll missing errors when opening outlook and IE and other stuff.
i see the urlmon.dll file in my System32 folder but i keep getting errors
chrome browser works but whenever i try to download something it says the file download was blocked.
There is no known virus blocking as it comes back clean and fairly new computer

anyone have any idea how to fix this?
andrew nycAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

flubbsterCommented:
Have you tried to re-register it? If not, please give this a try:

Start>run

In the run box, type the following, then hit <enter>

regsvr32 C:\windows\system32\urlmon.dll

You should get a message saying that it was successfully registered. Reboot and test.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flubbsterCommented:
It sounds like it may have been replaced with a rogue dll or it may be corrupt. Verify that it is the exact name it has to be. Also, can you report the size? Running Windows 7 Pro here and mine is 1238Kb with a date of 3/26/15. Your date may be different based on updates, version, etc.
andrew nycAuthor Commented:
it said it registered but i restart and still have the same issues
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

andrew nycAuthor Commented:
is there a way i can copy the dll from another computer on my network?
jcimarronCommented:
andrew nyc--
"32-bit DLLs that are placed in the System32 folder on a 32-bit system must be placed in the SysWOW64 folder and registered there" when you use a 64 bit regsvr32 command.
This is explained here
http://csi-windows.com/blog/all/73-windows-64-bit/378-fixing-qregsvr32-the-module-failed-to-load-the-specified-module-could-not-be-foundq
flubbsterCommented:
Yes, it can be copied. Glad it registered correctly. It is an integral part of Internet Explorer. What version of IE are you running?
andrew nycAuthor Commented:
the filesize is 1,511
outlook 07 and IE 10 are both having the issues.

so copy the same dll to syswow64 and register it and restart?
andrew nycAuthor Commented:
ok so i copied to syswow64 and registered and restarted  now  i get a concentr.exe error  app was unable to start correctly (0xc000007b)
flubbsterCommented:
When did you get that error? At startup or when launching IE?
andrew nycAuthor Commented:
at start up  and IE launches but black without buttons and does not go to websites
outlook still does not work either,  it actually launches then a dw20.exe error ops up and disappears quickly and then i get a application crash send error notification
flubbsterCommented:
That error is related to Citrix online plug-in connection center. I assume you use Citrix and installed it yourself?
andrew nycAuthor Commented:
i will delete citrix if that can start to correct things.
 but i still am getting outlook issues and iE doesnt even work.  
should i try to delete citrix and then see what happens and follow thee steps again?
can the .dll be corrupt?
flubbsterCommented:
You may need to do a repair of IE. You may just want to download the best version for windows 7 which is IE 11. It can be downloaded from here:

http://windows.microsoft.com/en-in/internet-explorer/ie-11-worldwide-languages

Scroll down to English and then select the version you need 32/64 bit and download. It should replace any bad dll's during the install.
flubbsterCommented:
Try the download and go from there.
andrew nycAuthor Commented:
ill try that to fix and then downgrade, because of a stupud banking plugin we use we are not able to upgrade to IE 11 because it doesnt work with their system, yes i know everyone complains  and they are the top 5 banks in the world and they are so outdated.

anyway is that what you suggest i do? upgrade then downgrade?
andrew nycAuthor Commented:
also i can not download it on that computer because  IE does not work either does chrome, chrome says files downloaded are blocked
flubbsterCommented:
You may have to. I am looking for a stand-alone download for IE 10 and no luck so far.
andrew nycAuthor Commented:
i just grabbed a stand alone for ie11 and saved it over the network to that computer
jcimarronCommented:
andrew nyc--
Since your bank has rules about what can be done, do you have an in house IT department that can help you?

Otherwise I would suggest a Repair Install
http://www.sevenforums.com/tutorials/3413-repair-install.html
That should not affect installed programs or personal data.
flubbsterCommented:
Try the above first so you don't have to downgrade.
andrew nycAuthor Commented:
i tried to do a repair already and that failed, I am part of the IT staff here and i cant seem to figure it out at all. all the methods i know that should work dont seem to work.  At this moment it would be faster and more productive just to reformatt the computer so that the broker can get back online and start making money. if they are without a computer for more then a few mins i hear them complain they are losing money.. haha ill try a few more things and if all fails ill reformat.
jcimarronCommented:
andrew nyc--
Are you sure that was a Repair Install and not a Startup Repair?
joinaunionCommented:
Have you tried uninstall via add/remove programs? Reinstall after uninstall.
andrew nycAuthor Commented:
yea i got an error not sure what it was but said he could not complete
joinaunionCommented:
Try forcing uninstall with this via command line. Copy and paste in command prompt.

FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*10.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /quiet /norestart"

From option #4 here. You can also try other methods on the link.
http://www.sevenforums.com/tutorials/282216-internet-explorer-10-install-uninstall-windows-7-a.html
jcimarronCommented:
andrew nyc--
What was the solution?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.