Samsung Android S6 will not connect to Exchange 2013 server

Good Afternoon,

I have an on premise Exchange 2013 Server and a new Samsung 6 phone.

I tried to use the native phone app to set-up exchange, and it didn't work (no errors, just does not sync anything, and can't send out). Samsung Techs have no idea. I downloaded two recommended Email apps for android (Outlook and another) and they both do not work.

I set-up a test email account on the Exchange server and it works perfectly on the same Samsung 6 phone.

Other user accounts on the Exchange server work fine on other mobile devices.

My email store is roughly 2.5GB and according to samsung, that should not be an issue.

OWA works fine.

Outlook within the network works fine.

I tried using another mobile device (Blackberry Tablet) and it does not work with my account either.
I'm guessing there is an issue with Exchange, even though it is not obvious.

Any suggestions would be helpful.

Thank you!
2ndFloorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

infedonetworkCommented:
Are you trying from inside the network with a wireless connection to the server?
2ndFloorAuthor Commented:
Most of my testing is from the outside of the network, connecting through 4G cell towers or WiFi hotspots.  Knowing some hotspots might block ports, we have confirmed other phones have connected using the same WiFi networks without any issues.
infedonetworkCommented:
Try to delete all the devices on one account from exchange then try again but do not use any other app for testing other than the one that come with Samsung 6. Just go to settings, Accounts and chose Microsoft exchange and chose manual setup. Make sure for user name you use domain\user name and make sure SSL is check and I assume you already open port 443 and FFW to the exchange server on the firewall since you said that other devices work fine.
Just try to clean all devices on one account for testing then try again.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

2ndFloorAuthor Commented:
I have no devices associated with my email account.

I log in through owa and under options/phone, there are no phones listed.

The last couple days I have only used the native email app with the samsung.

SSL is always checked, and 443 is open and forwarding to the Email Server.
2ndFloorAuthor Commented:
Solution found.
Apparently my AD account did not have 'Create msExchangeACtiveSyncDevice Object' and 'Delete msExchangeActiveSyncDevice object' permissions.
Edited the permissions an the phone now works perfectly.

Thanks!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
2ndFloorAuthor Commented:
I accept my own comment as the solution because it fixed the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.