Office 2010 only works as an Adminstrator

I am using Office 2010 on a 2008 Server (Standard Version) . However both Excel and Access load but only show the ribbon at the top and no data in the file I am opening. I can open the program without a file and if I then try to load a file Excel says "The program has stopped working - Find a solution on line"

Access same problem, but the error code is The Visual Basic for Applications Project is corrupt.

If I log on with a local account it works fine - If I log on through the domain as an administrator it works - just when logged on as a user on the domain it fails.

I have uninstalled and reinstalled Office 2010 and also tried Office 2007 - same problem   I  am aware that Office 2010 is not supported on Server 2008 R1, but this had been working for over a year with no problems.

Any ideas?
jontyplattAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
Uninstalling and reinstalling almost never fixes things!  Instead, go to programs and features in the control panel and do a repair, first as an admin and then as a user.  Did that fix things?
0
Adam BrownSr Solutions ArchitectCommented:
Check group policy on the server, then check the NTFS permissions on the Office folder in Program Files. Also, there may be some user rights missing on the server. Mostly this seems like a permissions issue to me, so I would start looking there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CoralonCommented:
Is this a terminal server?

Coralon
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jontyplattAuthor Commented:
Yes it is a terminal server - but I am only using it locally until I sort this out
0
Davis McCarnOwnerCommented:
Take 2:
"Uninstalling and reinstalling almost never fixes things!  Instead, go to programs and features in the control panel and do a repair, first as an admin and then as a user.  Did that fix things? "
0
CoralonCommented:
Do you have the option to rebuild the entire server?  If so, I would definitely start there.  It is sounding to me like the installation *is* corrupt.  I would validate your install media to make sure it is not corrupt.

And of course, make sure you do a change user /install before you install it.  (Personally, I always create an admin install with office, that way I can always reinstall it exactly the same way).

If you can't reinstall it, then I would uninstall it, and then manually hack out all of the files and as much of the registry entries as possible, *and* I would clear out all the profiles.

Coralon
0
jontyplattAuthor Commented:
The repair works under the local Administrator account - but I still can't load Access or Excel, with the administrator on the domain I get a C=++ Run time error - please see attached - I also enclose a screen shot of what I get when I open Excel

I have checked the permissions on the Program Files - Common Files as well - all seem ok

I really don't want to rebuild the entire server if has several applications on there that are used throughtout the school

Thanks
RunTime.jpg
0
Davis McCarnOwnerCommented:
C++ runtime errors are almost always caused by an add-in.  What Office add-ins have been installed?
0
jontyplattAuthor Commented:
I have  disabled the add ins - still not working - have moved the remote desktop to another machine - will probably have to rebuild this machine - but thanks
0
Davis McCarnOwnerCommented:
Did you try a repair after removing the add-ins?
0
CoralonCommented:
Defintely a corrupted install if the add-ins are disabled.   I would strongly look at reinstalling at least Office.

One relatively important thing to do is create an Admin install of your Office.  This will let you reinstall at any time maintaining the same installation settings every time.  (setup.exe /admin to start the Office Customization Toolkit, and setup.exe /adminfile <file> to install it with the MSP you created.

Coralon
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.