Sql Server Mgmt Studio - how to disable Authentication dropdown

I have a requirement : When connecting to Sql Server, I can login with Windows Authentication or SQL Server Authentication from Authentication drop-down. I want to disable this drop-down by keeping only Windows Authentication option for login, that is all users must login only with Windows Authentication.

i cannot set the option in SQL server as i required common SQL users to be authenticated using application . so i just need to harden my MSSQL Managment studio for locally restricted users as they can only access using windows authentication and cannot be connect the SQL server using dropdown.

Kindly guide me .
Murugesh PerumalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ste5anSenior DeveloperCommented:
Imho you cannot change this.

But this should be irrelevant at all. When your server only allows Windows authentication, then data entered by SQL authentication will be ignored.

When you're running it in mixed mode, and a user (??? users should not use SSMS imho), then he is obviously authorized to do that.

When you want to avoid that users have the same access as your applications, then use application roles.
0
Aaronc GrayCommented:
Altough it's not important to set the authentication mode to server authentication in the development stage. as you'll change the Connection String to your deployment server settings. so by then, you could add the authentication type and the user and password very easily and it won't affect your code.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
You can't disable but what you can and should do is to set the SQL Server instance to only allow Windows authentication mode so if somebody tries to connect with a SQL Server login will get an error message.
I wrote an article about this if you're interested in reading it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TemodyPickalbatros, IT ManagerCommented:
To change security authentication mode
In SQL Server Management Studio Object Explorer, right-click the server, and then click Properties.
On the Security page, under Server authentication select windows authentication mode, and then click OK.
In the SQL Server Management Studio dialog box, click OK to acknowledge the requirement to restart SQL Server.
In Object Explorer, right-click your server, and then click Restart. If SQL Server Agent is running, it must also be restarted.
0
Walter RitzelSenior Software EngineerCommented:
I'll make easier for you: there is no way to change the behavior of SQL Server Management Studio. It will always open the dialog box.
That said, if any user of your application knows the password of certain sql users, do a favor for your security: change it all and never let everyone know unless they a are from your support team. Better yet, restrict the IP's from where these sql users can log in.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.