ipad2 - pages app stuck in loading state and will not delete

i have been trying to download the pages app that i purchased. i can hit the little cloud button but it never fully installs. there is an icon on the homepage that says loading but it never goes away.
steps taken to try to resolve
1) soft reset
2) hard reset
3) took and reset the settings in general
4) tried to long hold the app and delete (will not delete)

any thoughts other than blowing it away or installing itunes and potentially having a sync issue and  removing/losing apps?

thanks!
bbimisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle SantosCustomer RelationsCommented:
Does the iPad have cellular data or is it just equipped for wifi?

What is the 'pages app' name, manufacturer?

What happens if you go to the app store and try to download the app again?

Try logging out of your app store account and then logging back in and trying the steps you've already tried.

Sometimes Apple requires a valid (or updated) credit card to be on the account.  Did you use a Visa gift card to purchase the app?  Has the purchase gone completely through on your end and not in a pending state anymore?

Last resort:

1. You contact the manufacturer and ask them for help.

or

2.  If none of those above things work, personally I would be plugging it into my computer, loading up iTunes and restoring the device back to a previous backup you have, and then trying again to download the app.

Let me know how that goes.

o/
0
David AndersTechnician Commented:
http://ipadacademy.com/ipad-app-stuck-on-installing-how-to-get-app-downloads-started-again/
Things to try....
1] Choose and download a new app from the App Store. Any free app will do.

2] Go to the App Store app and tap on the Purchased tab. Find the problem app in the list and tap the little cloud.

3] Tap the app’s icon on the home screen to pause the download. Return to the App Store. Tap the Updates button to get a list of app updates. Find the problem app and tap the Update button for the app.

4] Go to Settings > General > Usage. Under Storage you’ll find a list of apps. The stalled apps should show up in this list. You may need to tap Show All Apps to find them. You can delete the app(s) and redownload again.

5] Go to Settings > iTunes & App Stores. Tap your Apple ID and choose Sign Out. Restart the iPad. Return to Settings -> iTunes & App Stores and sign in. Find the problem app on your Home Screen and tap the icon.

Maybe the problem really isn’t an app that’s stuck. There may be a download stuck in another area such as a song or podcast that is preventing the app(s) from updating. Go to the iTunes app on your iPad (the purple icon). Check to see if you have any downloads pending there. That pending download may be blocking app updates. If so, delete the item. That may get the app installation going again.

Another link with similar suggestions...
http://www.imore.com/apps-stuck-downloading-after-restoring-icloud-heres-fix
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bbimisAuthor Commented:
thanks got it working!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPad

From novice to tech pro — start learning today.