FileMaker 13 Port 80 Problem on server 2012

I've disabled all the services that would be listening on port 80, so that I can install FileMaker Server 13.  I get a message like this, when attempting to use PowerShell to stop the Http service:



C:\Users\Administrator>net stop http
The following services are dependent on the HTTP service.
Stopping the HTTP service will also stop these services.

   Web Management Service
   World Wide Web Publishing Service
   Print Spooler
   Web Deployment Agent Service
   Function Discovery Resource Publication

Do you want to continue this operation? (Y/N) [N]: y
The Web Management Service service is stopping.
The Web Management Service service was stopped successfully.

The World Wide Web Publishing Service service is stopping.
The World Wide Web Publishing Service service was stopped successfully.

The Print Spooler service is stopping.
The Print Spooler service was stopped successfully.

The Web Deployment Agent Service service is stopping.
The Web Deployment Agent Service service was stopped successfully.

The Function Discovery Resource Publication service is stopping.
The Function Discovery Resource Publication service was stopped successfully.

The HTTP service is stopping........
The HTTP service could not be stopped.


Changing the active listening port gives a handle exception:

IP address add failed, Error 6
The Handle is Invalid

Looked at https://www.devside.net/wamp-server/opening-up-port-80-for-apache-to-use-on-windows

Stumped at this point.  Ideas?
fxr1216Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zac HarrisSystems Administrator Commented:
Do you have the Microsoft Web Deployment Service (MSDEPSVC) installed on this system?

If you do, you will need to stop that service in order for the HTTP service to stop. The Microsoft Web Deployment Service is dependent on the HTTP service. The dependency is not registered when it's initially installed but when the command to stop HTTP is issued, one of the steps is to stop all services that are dependent on it.

The system polling shows that service is installed and since its a dependency it prevents the HTTP service from stopping.
0
Zac HarrisSystems Administrator Commented:
You can also run this powershell script on the server to ensure that all dependencies of the HTTP service are properly registered. That way when you go to stop the HTTP service it will be sure to stop all the dependencies.

$bFoundHttp = $false
$msdepsvc = Get-Service -name MsDepSvc
$reqsvcs = "HTTP"
$msdepsvc.ServicesDependedOn | ForEach-Object `
{
    if($_.Name -eq "HTTP")
    {
  $bFoundHttp = $true
    }
    else
    {
    if($_.Name -ne "")
 {
     $reqsvcs += "/" + $_.Name
 }
    }
}
if ($bFoundHttp -eq $false)
{
    $status = $msdepsvc.Status
    if($status -eq "Running")
    {
 Stop-Service -name MsDepSvc
    }
    
    sc.exe config MsDepSvc depend= $reqsvcs
    if($status -eq "Running")
    {
 Start-Service -name MsDepSvc
    }
}

Open in new window

0
fxr1216Author Commented:
It is not installed.  I checked all the services/roles that might  be installed.  Nothing shows, and only PID 4 shows as using http.sys
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Zac HarrisSystems Administrator Commented:
Right, but if the service is not "properly registered" it won't show up. What is the result of running the Powershell script I attached?
0
fxr1216Author Commented:
Thanks, I ran that earlier:

Get-Service : Cannot find any service with service name 'MsDepSvc'.
At line:1 char:13
+ $msdepsvc = Get-Service -name MsDepSvc
+             ~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (MsDepSvc:String) [Get-Service], ServiceCommandException
    + FullyQualifiedErrorId : NoServiceFoundForGivenName,Microsoft.PowerShell.Commands.GetServiceCommand

That's what I got
0
fxr1216Author Commented:
FWIW, this is on a VM running on Xen.  Haven't seen anything to indicate it would be any sort of problem.
0
Zac HarrisSystems Administrator Commented:
ok, try going into Powershell as an admin and type:

net stop http /y

Open in new window

and press enter

You can't stop PID 4 its a system process.
0
fxr1216Author Commented:
Sorry, I was out due to the flu.  the net stop http was the first thing I tried.  It stopped several services, then hung, resulting in the message "The http service could not be stopped".  Is there any way I can prevent it being called by PID 4 on startup?
0
Zac HarrisSystems Administrator Commented:
No worries :)

Since PID 4 is a system process you have to disable the HTTP.sys driver. This driver is started on demand by some other service, such as Windows Remote Management or even the Print Spooler.

There are two ways to do this but I recommend using the 1st one.

1. Go to device manager, "select show hidden devices" from menu/view, go to "Non-Plug and Play Driver"/HTTP, then double click it to disable it.

Reboot and use netstat -nao | find ":80" to check if port 80 is still being used.

2. launch Regedit
Go to Hkey_Local_Machine\System\CurrentControlSet\Services\HTTP
Change the value of "start" to 4 which means disabled
Reboot

Give this a shot and let me know.

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fxr1216Author Commented:
Thanks for working with me on this, Zach.  So far, I haven't seen an option for the HTTP service in Device manager.  Looks like the Regedit trick might have done it.  Funny that it didn't pop in forums..  Should have thought of it, but oh well..
0
fxr1216Author Commented:
Zac Harris, thanks for continuing to follow up until we found a solution.  Much appreciated!
0
Zac HarrisSystems Administrator Commented:
No worries... Glad I was able to help you out!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.